Showing results for 
Show  only  | Search instead for 
Did you mean: 

Appbroker and Workspace one Integration


I know this might not be an appbroker issue, as we are using custom developed PowerShell script to send request to UEM workspace one for deployment, but we tried everything already still do not need the answer so just hope somebody might see this issue before can point us to the right direction. Basically we are sending the request form appbroker to UEM, here is the error log: 

Invoking command powershell.exe with args: " & 'E:\Program Files (x86)\Flexera Software\App Portal\Web\Uploads\Commands\UEM-ProvisionSoftware2.ps1'"  ****

Error executing Command E:\Program Files (x86)\Flexera Software\App Portal\Web\Uploads\Commands\UEM-ProvisionSoftware2.ps1 with args: **  No such interface supported at System.Diagnostics.Process.StartWithShellExecuteEx(ProcessStartInfo startInfo)
at System.Diagnostics.Process.Start(ProcessStartInfo startInfo)
at SelfService.CommandAction.invoke()


anything  thoughts what might be causing this issue? 








(3) Replies
By Level 12 Flexeran
Level 12 Flexeran

This looks like some type of environmental issue, or an issue with .NET. Perhaps a recent update to the system? I'd assume that this would happen with any file you attempt to launch as a command.. As a quick test, can you try running the following powershell script.. it uses the same .NET calls as App Broker, so it would not surprise me if this fails as well. It simply launches notepad, and waits for it to complete:

$startInfo = New-Object System.Diagnostics.ProcessStartInfo
$startInfo.FileName = "c:\windows\notepad.exe"
$process = New-Object System.Diagnostics.Process
$process.StartInfo = $startInfo
$process.Start() | Out-Null


Thanks for getting back to me, but no, i tried to run as administrator and it successfully opened a notepad without any issues. 

We probably need more specific configuration information if you can provide it (perhaps submit a support case if you can't post here due to confidential data).  Do you have literal asterisks (****) as a command line parameter in your command action?  Can you provide screenshots of your command action configuration and perhaps a copy of your script?

Anything expressed here is my own view and not necessarily that of my employer, Flexera. If my reply answers a question you have raised, please click "ACCEPT AS SOLUTION".