Showing results for 
Show  only  | Search instead for 
Did you mean: 

error code 1603

Hi All, I hope I am in the right forum. I may sound confusing but I hope someone may be able to help me!

I am using Zenworks 7 with Admin Studio 9. First of all I am very new to the MSI installs and creations.

I think I have followed the steps to create an msi from the exe of one of the applications that we use in our schools. No matter what application I try to create an msi for I get errors.

First I get an error of "msi returned error code 1603" which I assume is a windows installer error! I cannot get any of my applications to install.

2nd I get an error of "The application cannot continue because a system reboot is pending" This happens when I run the application in the run line.

If I set up the object and point it to the exe file and add a Transform I get another windows installer error. "This installation package could not be opened. Verify that the package exists and that you can access it or contact the application vendor to verify that this is a valid windows installer package"

When I looked at the Transform verification I see another error of "ICE27" Unknown action MSIConfigurationServices" of Install Execute Sequence table. Not a standard action and not found in Custom Action or Dialog tables.

I have no idea of what this means???

As I said I am very new to Admin Studio and creating msi's, I was doing snApp shots with Zenworks. please note that I have not had any training with Admin Studio 9 and Zenworks.

Can you at least point me in a direction that I can get some answers or help.

I am using windows XP sp 2 with systems that have 512 Mbs - 2 Gigs in a school classroom setting

Thank you very much!
(3) Replies
Hi Kathy,

Error 1603 is quite generic (meaning basically ERROR_INSTALL_FAILURE).

Generally the way to work this out is to generate a logfile of where the 1603 is occurring:

msiexec.exe /i package.msi /l*v install.log

Or via the MSI logging policy, which puts the log in %TEMP%:

I would say, just post the entire log here and we can have a look at it. Generally, though, the process is to start at the bottom and work your way up until you see the error.

Thanks Cary

I went into the HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer and created a string value called logging with a value of v. I ran the application again to create a log file. I do not know where the logging file would be so I did a search for logging on the C dive. I found an error on the logging that says "Jave Virtual Machine Launcher. Failed to load Main Class manifest attribute from C:\Program files\my app\lib\jlayer\commons-logging-api.jar

Any ideas?
Hi Kathy,

I'm surprised to see some sort of java error in the MSI log, actually. So perhaps let's make sure we have you looking in the right place:

1. The logging policy for a full verbose log, make sure it's set to 'voicewarmup' instead of just 'v'. This gives you all possible information.

2. The logfile typically shows up in:

C:\Documents and Settings\Your User\Local Settings\Temp

And it should have a naming convention of MSI###.log

This should be the one that gives us the error--I would just attach the logfile, since it's going to be rather big to post as a message.