Showing results for 
Show  only  | Search instead for 
Did you mean: 

Not a Legal Form - Software Repository

I'm trying to set up Admin Studio 2021, and have set up the database on our SQL instance, however when I'm trying to set up the software repository I keep running into the below error, which fails to create the repository afterwards. (see attached screenshot and below example)

The path is not of a legal form.
One or more errors occurred.


Does anyone have any suggestions? I'm using the following path:


Are UNC paths not supported? I tried just going to C:\temp as a test and it gave the same error there. I'm not sure what to do to get the repository set up. Any help from any expert users? 

(3) Replies
Flexera Alumni

It is looking for the server where SQL is running, not a file path. Here are some specific resources to help you along...

This must be something else that's broken. I unchecked the software repository checkbox, and it still errored out with the same error. I can't seem to get any catalogs created. 

Hi @MoSpartan 

Just to review: Software Repository requires the full path to the root of a folder share (UNC path is best) as well as a proxy account that everyone that connecting and using that associated Application Catalog will connect to and use to read to and write from the share.  As the help article indicates on the dialog box (also found online here) :

IMPORTANT: The Proxy Account needs full control on the Software Repository Location folder at the directory level as well as at the sharing level.

I would double-check that the proxy account you've provided is setup per those requirements for that location.

Expert Flexeran on AdminStudio, Workflow Manager, and Software Vulnerability Manager / Research
If I've answered your question, please mark my response as "Accept as Solution" to help others find answers. Thanks!