Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error 1919 ODBC error:8

i am very new in installsheild. I had created a software package for NT, like setup.exe. this software require Mdac2.7. so i package with this software. Everything went fine, except for when i run setup.exe on client's computer, at the end i get error message.
"Error 1919. Error configuring ODBC data source Sql Server,
ODBC error 8: invalid keyword-value pairs. Verify that the
file SQL server exists and that you can access it".
I know its not a permission issue (or may be) because I am installing as a local admin.
I am using InstallShield Developer - AdminStudio Edition 5 version. Any help would be very very appriciated.

Thanks in advance
(6) Replies
Pls make sure if you have checked the option "Map registry data to the appropriate ODBC tables" in the Repackaged IDE under Repackaged Output - Advanced settings view when building the MSI.
i have check that box..but still same error when you tried to installed package. if i click ignore it, package installed fine.

So, please let me know how to get rid of this message.

thanks in advance
Based on the error, I am assuming that one of entries in the ODBCSourceAttribute table is incorrect.

Create a log file for the installation using the following command line to determine which ODBCSourceAttribute is incorrect:

msiexec /i /lv*

Then, open the MSI package in Developer IDE. Go the Director Editor and Select the ODBCSourceAttribute table. In this ODBCSourceAttribute Table remove the value, pair that is incorrect and the try installing the package again.

This should help you narrow the problem down.
when i tried to run
msiexec /i c:\setup.exe /lv c:\error.txt

i am getting error"
By Level 11 Flexeran
Level 11 Flexeran
If the original install was created with InstallShield, you can create an administrative install by using the following command:

setup.exe /a

The /a switch causes Setup.exe to perform an administrative installation. An administrative installation copies (and uncompresses) your data files to a directory specified by the user, but does not create shortcuts, register COM servers, or create an uninstallation log.

Once the administrative image is created, you can then run the following command line and get the log file.

msiexec /i /lv*
Actually i had fixed this problem.
MQIS entry was in ODBC Resources, SQL Server, Dsns. once i had removed it and create registry entry to point my odbc driver. works Charms... walllla...