cancel
Showing results for 
Search instead for 
Did you mean: 
petri_siiskone
Flexera beginner

Error with XULRunner when updating Firefox

Jump to solution
We have used Secunia several years for updating Firefox without problems, but now update seems to broke Firefox. After updating when you try to start Firefox, it gives error about XULRunner platform version. Kind regards, Petri
1 Solution

Accepted Solutions
Community Manager RDanailov Community Manager
Community Manager

Re: Error with XULRunner when updating Firefox

Jump to solution

Hi Petri,

I sent an email to you this morning which points to where the problem originated and also provides you with steps to solve the issue by using the "Perform Clean Install" setting in our Firefox packages. For the sake of transparency to help other users who might run into this, here is what causes such issues:

https://support.mozilla.org/en-US/questions/1173274

Attached to this comment you will also find a quick screenshot showing the options that could solve this.
To solve such issue, new package must be re-deployed to affected systems with this enabled in it. 

Machines that already ran previous package with the newest versions might need package re-enforcement.
This could be done by enabling the "AlwaysInstallable" option, but then you have to approve the patch only to machines who have Firefox on them via WSUS/SCCM and be careful to not include systems that didn't have it.

Regards,
Rosen
"To understand where a system breaks, one should think like the person who built it"
0 Kudos
2 Replies
Community Manager RDanailov Community Manager
Community Manager

Re: Error with XULRunner when updating Firefox

Jump to solution
Hi Petri, Can you edit this same Firefox package (right-click > Edit) through "Patching > Available" menu in SVM, then go to step 3 of the SPS wizard, and note down the "minimum version" field? What number was seen there? Also, what is the exact version number of the installed Firefox package that led to this error?
Regards,
Rosen
"To understand where a system breaks, one should think like the person who built it"
0 Kudos
Community Manager RDanailov Community Manager
Community Manager

Re: Error with XULRunner when updating Firefox

Jump to solution

Hi Petri,

I sent an email to you this morning which points to where the problem originated and also provides you with steps to solve the issue by using the "Perform Clean Install" setting in our Firefox packages. For the sake of transparency to help other users who might run into this, here is what causes such issues:

https://support.mozilla.org/en-US/questions/1173274

Attached to this comment you will also find a quick screenshot showing the options that could solve this.
To solve such issue, new package must be re-deployed to affected systems with this enabled in it. 

Machines that already ran previous package with the newest versions might need package re-enforcement.
This could be done by enabling the "AlwaysInstallable" option, but then you have to approve the patch only to machines who have Firefox on them via WSUS/SCCM and be careful to not include systems that didn't have it.

Regards,
Rosen
"To understand where a system breaks, one should think like the person who built it"
0 Kudos