Symptoms:
SVM Patch Daemon shuts down and stops the service. Error can be found in Daemon's svmpatch.log file in located in C:\ProgramData\Flexera Software\SVM Patch.
Diagnosis:
The error relates to Daemon not being able to connect to Flexera server's SCCM directory.
Solution:
Error is most commonly related to Internet access proxy. Running Daemon as a service account with proxy access will resolve the issue. It is enough to enable access to Product URLs as listed here https://docs.flexera.com/csi/Content/helplibrary/System_Requirements.htm
You can install and runt the Daemon as a Local System account. But it will most likely result in the above error since it is not a standard practice to allow a Local System account through proxy for the security purposes.