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Known Issue: Unhelpful "Index was out of range" error when activation wizard is invoked without admin rights, or with a misconfigured database (IOJ-2243204)

Known Issue: Unhelpful "Index was out of range" error when activation wizard is invoked without admin rights, or with a misconfigured database (IOJ-2243204)

Summary

This article describes possible reasons why you may be unable to open the FlexNet Manager Suite license activation wizard and receive an error message indicating "Index was out of range".

Symptoms

When attempting to run the activation wizard (ManageSoft.Activation.Wizard.exe), it fails to open and instead displays the following error:

---Problem---

(s0m0): The activation wizard failed to initialize.

---System exception---

Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index

---Source---

mscorlib

---Stack trace---

System.ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
at System.Collections.Generic.List`1.get_Item(Int32 index)
at ManageSoft.Activation.Executable.RunWizard()
at ManageSoft.Activation.Executable.Main(String[] args)

Cause

There could be two causes to this issue:

  1. The user account used to open the activation wizard does not have administrator rights in FlexNet Manager Suite.
  2. If the inventory database and compliance database are both stored in the same physical database, and the compliance database schema was configured before the inventory database schema was configured. This is because these databases share the same dbo.TenantSecurityInfoGetAll stored procedure which is used by the activation wizard. The implementation of this procedure differs in between the inventory and compliance databases, and will be incorrectly configured if the inventory database schema was configured last.

Resolution

For cause #1, ensure that the activation wizard is invoked using an account that has full administration rights in FlexNet Manager Suite.

For cause #2, the following SQL can be executed against the shared inventory/compliance database to correctly configure the TenantSecurityInfoGetAll stored procedure:

ALTER PROCEDURE [dbo].[TenantSecurityInfoGetAll]
AS
BEGIN
    SELECT
        t.*
        ,fl.License
    FROM
        dbo.TenantsActiveWithPermission(NULL) AS t
        LEFT OUTER JOIN dbo.FlexeraLicense AS fl ON t.TenantUID = fl.TenantUID
END
GO 

Fix status

This issue is still open but not currently scheduled to be addressed.

Other information

Affected components: Database, Operators, rights and roles

Master issue ID: IOJ-2243204

Also known as: FNML-75106

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Version history
Last update:
‎Jun 12, 2022 03:50 AM
Updated by: