cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Summary

The Serial number is not displayed for Host ESX servers via vCenter even though the VMware infrastructure and a full inventory has been performed.

Symptoms

When view vCenter inventory the serial number for the Host machine is not present even though VMware infrastructure and a full inventory has been performed and imported successfully, why is this?



Cause

The cause of the issue is related to how vCenter stores the serial number, the serial numbers are stored in a cache that expires, if this cache has expired and the before the inventory tasks are completed no serial number will be reported.


Workaround

To workaround this issue please restart the "vCenter Management Agent" this restores the cache that contains the serial number, for steps on doing this please consult with the vCenter Administrator.


Additional Information

The Inventory tasks collect the Host serial number from the "ServiceTag" property, the following steps can used to determine if this value is populated in vCenter.

1. Navigate to "https://vcenterservername/mob" where vcenterservername is the vCenter server.

2. Login using an appropriate vCenter account

3. Navigate to HostHardwareInfo/HostSystemIdentificationInfo data on the host machine missing the serial number

4. Verify the "ServiceTag" attribute is populated.

Was this article helpful? Yes No
No ratings
Version history
Last update:
‎Jun 09, 2018 02:09 AM
Updated by: