SQL Server Edition Information Not Being Retrieved by the FNMP Inventory Manager Agent

SQL Server Edition Information Not Being Retrieved by the FNMP Inventory Manager Agent

Summary

If SQL Server (unknown component) is the only SQL Database software record that gets recognized from the Managesoft agent inventory, it's likely that there is a WMI Namespace access problem with that system.

Symptoms

If SQL Server (unknown component) is the only SQL Database software record that gets recognized from the Managesoft agent inventory, it's possible that there is a WMI Namespace access problem with that system.

 

Cause

This is usually caused because the agent cannot gather the WMI class information from the server, there could be a couple of causes for this including access issues, corrupt namespace, etc.

Please follow the Resolution section below to find more detail.

Resolution


1. On the SQL Server machine in question, launch 'wbemtest' from the run menu

2. Press 'connect' and connect to the following namespace:

*If SQL Server 2005 & earlier - root\Microsoft\SqlServer\ComputerManagement
*If SQL Server 2008 - root\Microsoft\SqlServer\ComputerManagement10
*If SQL Server 2012 - root\Microsoft\SqlServer\ComputerManagement11
*If SQL Server 2014 - root\Microsoft\SqlServer\ComputerManagement12

3. After connecting to the namespace, click Enum Instances and do a search for "sqlservice" in the superclass name field

Look for any MSSQL instances (serviceType=1) in the query resultsUser-added image

4. If MSSQL doesn't show up in this list then run the following command:


*If SQL Server 2005 or below:
mofcomp "%programfiles(x86)%\Microsoft SQL Server\90\Shared\sqlmgmproviderxpsp2up.mof"

If SQL Server 2008:
mofcomp "%programfiles(x86)%\Microsoft SQL Server\100\Shared\sqlmgmproviderxpsp2up.mof"

If SQL Server 2012:
mofcomp "%programfiles(x86)%\Microsoft SQL Server\110\Shared\sqlmgmproviderxpsp2up.mof"

If SQL Server 2014:
mofcomp "%programfiles(x86)%\Microsoft SQL Server\120\Shared\sqlmgmproviderxpsp2up.mof"

User-added image

5. Re-run the wbemtest and check to see if any MSSQL instances now show up. If it does and the evidence still doesn't trigger a proper SQL Server recognition, then there could be an ARL mismatch problem with one of the WMI evidence records (IOJ-1659934). Ask for the NDI file for further debugging.

 

Additional Information

It's possible to verify the Edition value stored in the SKUNAME property in WMI as well by running the following query after connecting to the namespace in wbemtest:
select * from SqlServiceAdvancedProperty where SQLServiceType = 1 AND PropertyName = 'SKUNAME'

User-added image

Labels (1)
Was this article helpful? Yes No
No ratings
Comments

Does this fix work for SQL server 2017?  If so what is the path for step4?

I have several hundred of the unknown component installations along with regular, recognized, edition installations. I can't possibly ask SQL team to cycle through all those devices. Isn't there any better workaround?
Also, is there anything that SQL can do to prevent this issue from happening while they deploy a new instance of the SQL? Prevention is better than cure.

I need this solution too, please!

Version history
Revision #:
4 of 4
Last update:
‎Jul 01, 2020 03:40 PM
Updated by: