Summary
The FNM Admin Java process consumes all the memory and impacts performance until restarted
Symptoms
The java process for FlexNet Manager Admin service seems to be consuming all the memory allocated to the machine. This build up over time until the interface becomes unresponsive and the machine/service needs to be restarted. This corrects the issue for a few days but the memory continues to increase until a restart is required again.
Cause
The cause of the memory consumption is related to a known issue we currently have reported and has been assigned the tracker number FNMEA-10238, this is currently scheduled for FNMEA 2016 R2 SP2.
Steps To Reproduce
-Start the FNM admin service.
-Make a note of the memory currently consumted by the java process
-Verify this gradually increases until the FNM UI becomes unresponsive and there is no free memory on the server
-Kill the Admin java process that is consuming the memory
-Restart the service and verify the FNM UI is responsive.
Workaround
The following can be used to workaround the issue:
-Ensure the FNM Admin, Reporting and Cognos modules are on separate machines, the exact specifications are outlined in the FNM release notes.
-On the Admin machine, stop the FNM service.
-Create a SYSTEM environment variable with the following "JAVA_OPTS=-Dcom.sun.xml.bind.v2.bytecode.ClassTailor.noOptimize=true", as outlined below:

-Restart the FNM Admin service.
-Monitor the memory performance.