Summary
This article explains how to update "Located in service provider's datacenter (cloud)" and "Service Provider" on cloud and on-premise environment.
Symptoms
It is a system limitation that "Located in service provider's datacenter (cloud)" and "Service Provider" in inventory device properties cannot be updated either from UI or via Business Adapter Studio.
Cause
It is a bug being tracked under FNMS-31159 and FNMS-31160.
Resolution
For cloud customer:
Please raise a support call with a list of computer names.
For on-premise customer
Please update table in "FNMP" database by using the following query.
UPDATE VirtualMachine
SET LocatedInCloud = 1, ServiceProvider = 'AWS'
FROM VirtualMachine vm
INNER JOIN ComplianceComputer cc ON vm.ComplianceComputerID = cc.ComplianceComputerID
WHERE ComputerName IN (
'ComputerName'
)
* Please replace 'ComputerName' with actual computer name.