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Summary

When performing a Compliance Import using FlexNet Manager Platform version 9.2 this fails with the error message below.

Symptoms

When performing a Compliance Import using FlexNet Manager Platform version 9.2 this fails with the error message below:

" Completed with error in 0 seconds.

FATAL: The import process has failed with the following error (use -verbose to see error details):

Error: The given value of type String from the data source cannot be converted to type nvarchar of the specified target column.

String or binary data would be truncated.

Error Details:

System.InvalidOperationException

at System.Data.SqlClient.SqlBulkCopy.ConvertValue(Object value, _SqlMetaData metadata)

at System.Data.SqlClient.SqlBulkCopy.WriteToServerInternal()

at System.Data.SqlClient.SqlBulkCopy.WriteRowSourceToServer(Int32 columnCount)

at System.Data.SqlClient.SqlBulkCopy.WriteToServer(IDataReader reader)

at ManageSoft.Compliance.Importer.Logic.DatabaseConnection.LoadData(IDataReader p_DataReader, String p_TableName, Int32 p_BatchSize)

at ManageSoft.Compliance.Importer.Logic.XML.SourceToTarget.ExecuteSQL(IExecutionContext context)

at ManageSoft.Compliance.Importer.Logic.XML.Reader.Execute(IExecutionContext context)

at ManageSoft.Compliance.Importer.Logic.ComplianceImporter.ExecuteReaders(ComplianceReader p_ComplianceReader, IExecutionContext context)

at ManageSoft.Compliance.Importer.Logic.ComplianceImporter.ExecuteComplianceReader(ComplianceReader p_ComplianceReader, Tenant tenant)

at ManageSoft.Compliance.Importer.Logic.ComplianceImporter.RunImport()"


Cause

This error is caused by an issue in the "InstallerEvidence.xml" inventory reader which is located in the following location by default.

"C:\ProgramData\Flexera Software\Compliance\ImportProcedures\Inventory\Reader\ManageSoft"


Workaround

The attached "InstallerEvidence.xml" can be used to resolve the issue, please follow the steps below to apply the updated "InstallerEvidence.xml" file to the system.

  1. Download the "UpdatedInstallerEvidence.rar" from the attachments section.
  1. Navigate to the current "InstallerEvidence.xml" and backup this file in another location.
  1. Replace the "InstallerEvidence.xml" in the directory with the file downloaded in step 1.
  2. Run the Compliance Import again.

Additional Information

The above issue has been assigned the reference number PA 79554 and is scheduled to be resolved in a future release. For an update on the issue please contact Technical Support with the PA number referenced above.

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Version history
Last update:
‎Jun 05, 2013 05:13 AM
Updated by: