cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Vendor log file is not collecting data

Jump to solution

I have updated my license file for Mentor Graphics to include an  Options line (highlighted in bold). I have stopped and restarted the license server but I am not collecting any data. Any ideas on why the report log is not collecting data?  The log file shows the vendor daemon is active

License File

SERVER Servername Macaddress 1717
DAEMON mgcld C:\MentorGraphics\Licensing\mgcld.exe port=4207
OPTIONS=C:\MentorGraphics\Licensing\Mentor.opt

 

Option file 

REPORTLOG +"C:\MentorGraphics\Licensing\Mentor_reportlog.rl"

 

Debug.log

23:36:57 (lmgrd) SLOG: FNPLS-INTERNAL-VL1-4096
23:36:57 (lmgrd) Starting vendor daemons ...
23:36:57 (lmgrd) Starting vendor daemon at port 4207
23:36:57 (lmgrd) Using vendor daemon port 4207 specified in license file
23:36:57 (lmgrd) Started mgcld (pid 3760)

0 Kudos
1 Solution
Paul_Diop
Level 5 Flexeran
Level 5 Flexeran

Hi @kdoyle 

It seems that the option file is not picked up. Can you reorder the vendor line to look like the following

DAEMON mgcld C:\MentorGraphics\Licensing\mgcld.exe OPTIONS=C:\MentorGraphics\Licensing\Mentor.opt port=4207
the option file needs to be before the port=4207. 

I would also recommend to rename the file from Mentor.opt to mgcld.opt. you can place it on the same location as that of the mgcld.exe so  "C:\MentorGraphics\Licensing\"

If you are still experiencing issues, or you do not see evidence on the debug log file that the option is picked up, remove the OPTIONS= keyword and do the following

DAEMON mgcld C:\MentorGraphics\Licensing\mgcld.exe C:\MentorGraphics\Licensing\mgcld.opt port=4207

I've seen rare cases where the OPTIONS= keyword was not picked by the vendor

Regards,

 

 

it 

 

View solution in original post

0 Kudos
1 Reply
Paul_Diop
Level 5 Flexeran
Level 5 Flexeran

Hi @kdoyle 

It seems that the option file is not picked up. Can you reorder the vendor line to look like the following

DAEMON mgcld C:\MentorGraphics\Licensing\mgcld.exe OPTIONS=C:\MentorGraphics\Licensing\Mentor.opt port=4207
the option file needs to be before the port=4207. 

I would also recommend to rename the file from Mentor.opt to mgcld.opt. you can place it on the same location as that of the mgcld.exe so  "C:\MentorGraphics\Licensing\"

If you are still experiencing issues, or you do not see evidence on the debug log file that the option is picked up, remove the OPTIONS= keyword and do the following

DAEMON mgcld C:\MentorGraphics\Licensing\mgcld.exe C:\MentorGraphics\Licensing\mgcld.opt port=4207

I've seen rare cases where the OPTIONS= keyword was not picked by the vendor

Regards,

 

 

it 

 

0 Kudos