ImIronMan
Level 6 Flexeran
Level 6 Flexeran

CSV Import error

Jump to solution

Hi Team,

We initially faced an error importing a csv file using the business adapter. The error was Text File specification field separator matches decimal separator or text delimiter.

So tried to update regional (data format) settings to decimal to . and list separator to ,

Still the error not gone. Then in business adapter studio, we selected 'semicolon' as the separator and updated the source CSV file with a semicolon instead of  a comma

This time, the error is gone and data imported to BAS. however, when we trying to map "computer name" property to the column "hostname" from CSV, the column headers from CSV are not shown as a list, instead shown as "hostname;role;costcenter".

So we could not map the columns properly. Attached screenshot for your ref.

Appreciate your assistance

Regards

Rajesh Ponnala

 

0 Kudos
1 Solution
mfranz
Level 16 Champion
Level 16 Champion

Hi Rajesh,

For semicolon to work properly, I usually do the following:

  1. In the import choose "None" as Column delimiter. It is no option from the drop down list, instead, you'll have to write it in there yourself.

    2019-11-26_16h16_43.png
  2.  Then create a schema.ini file in the same folder as your CSV file. There are many options to be used in a schema file. For this to work, you'll only need two things, the file name and the delimiter. Here is an example:
[Filename.csv]
Format=Delimited(;)

With this, instead of defining the semicolon as delimiter in the business import, it is done in the schema.ini file. 

Best regards,

Markward

 

Softline Group is Europe's leading independent expert in Software Asset Management.

View solution in original post

This thread has been automatically locked due to inactivity.

To continue the discussion, please start a new thread.

1 Reply
mfranz
Level 16 Champion
Level 16 Champion

Hi Rajesh,

For semicolon to work properly, I usually do the following:

  1. In the import choose "None" as Column delimiter. It is no option from the drop down list, instead, you'll have to write it in there yourself.

    2019-11-26_16h16_43.png
  2.  Then create a schema.ini file in the same folder as your CSV file. There are many options to be used in a schema file. For this to work, you'll only need two things, the file name and the delimiter. Here is an example:
[Filename.csv]
Format=Delimited(;)

With this, instead of defining the semicolon as delimiter in the business import, it is done in the schema.ini file. 

Best regards,

Markward

 

Softline Group is Europe's leading independent expert in Software Asset Management.