Workflow Manager may not be able to send emails, run scripts, or access file system templates if system settings are not configured properly.
Symptoms
Workflow Manager may not be able to send emails, run scripts, or access file system templates if system settings are not configured properly.
You may see errors in the Application Event Log similar to the following:
AMS Web Application Emailer Exception:AMSTemplateEmailer.SendEmail()
Exception information:
Type: System.Exception
Source: AMSBusinessLayer
Message: AMS failed to Impersonate as User 'AMS_SYSTEM' in Domain 'DOMAIN' Win32 Error Code is '####'
Cause
- A win32 error code of 1326 indicates "Logon failure: unknown user name or bad password".
- The account specified in System Settings may not have been granted the local policy of 'Logon Locally', which is required for ASP .NET User impersonation.
- In some situations, an invalid recipient can cause no notifications to be sent. In this case, the invalid user will be listed in the exception message, and no other recipients will receive an email since the entire email was not sent.
- Some customers have reported that Anti-malware software will block any SMTP traffic coming from the IIS worker process.
Resolution
1. Verify with your system administrator that the login information for the account as specified in 'System Settings' is valid on the machine or domain that you are authenticating to.
2. Verify that the account has the 'Logon Locally' permission granted in the Local Computer Policy. This can be accomplished in the following manner:
a. Run the command gpedit.msc
b. Navigate to Computer Configuration -> Windows Settings -> Security Settings -> Local Policies -> User Rights Assignments -> Log on locally.
c. Verify that the user or group has been granted this effective permission. If not, make certain that the account used for user impersonation has been added to this permission.
3. Ensure that there are no invalid recipients specified. This can happen if a group alias is not defined on the mail server, or if there are typographical errors in email addresses.
4. In the case that Anti-Malware, Anti-virus or Firewall software is being run on the web server, ensure that the appropriate exceptions are configured for IIS sending email via SMTP.
Additional Information