Showing results for 
Show  only  | Search instead for 
Did you mean: 

How to solve my MSI conflict?

Hello guys and girls. Here is my problem. I created an msi of one of our VB apps on a clean system. The msi works perfectly with other apps that we use (Office, Winzip, Adobe, Cognos..etc) The only app that i am having problem with is WRQ's Reflection X. If i load my MSI first and then try loading Reflection X install fails. If i load Reflection X first and then try loading my MSI. Reflection X will not run "RX.exe object manager is missing" My msi was created on a clean system. WRQ's Reflection X msi was build by the company. I tried using ConflictResolver, imported both msi, it found one key path missing, fixed that....still fails. What else should i try?

(3) Replies
Still no progress, but this is what i've done so fat. I decided to cheat, so i went ahead and installed Reflection X, then i did preinstall snapshot, installed my application, after install snapshot. Reflection X works fine so does my app at this point. I go ahead and create an msi from the information that was captured. Take my system with Reflection X installed (preconfigured image) and now i load my msi. It kills Reflection X again. Is it possible that Installshield install kills Reflection X, cause the msi was created on a system when Reflection X was already installed. I was trying to do this way to see if Reflection X was to work i would use MSIDiff to see if my initial msi was overwriting some files/components being used by Reflection X.

Any idea guys?

What version of AdminStudio are you using? Also, when you used ConflictSolver, what types of conflicts did you check for? After fixing the key file, did you reimport the modified package into ConflictSolver and check for conflicts again?
I fixed the problem. What it was , my application requres DCOM security settings to be set. So what i noticed was that when i created my msi with no DCOM security set at that point , Reflection X would work just fine. So apparently when setting DCOM security Access/Lunch permissions for my app, it would kill Reflection. Group that is entered in the DCOM settings was a Active Directory group, which means a user had to be logged in in order to run the app, i just went ahead and added local Administrators group to DCOM security Access/Lunch list. All of my users have Admin rights on their pc's anyway. Weird stuff, but i am glad i found a solution. The error message that Reflection X crapped out with did not give any hints that there could be a DCOM permissions error.