Showing results for 
Show  only  | Search instead for 
Did you mean: 

Warning-7065 Windows Installer 3.1 Engine could not be found, while creating a patch and "Error reading setup initialization file" on running patch

Warning-7065 Windows Installer 3.1 Engine could not be found, while creating a patch and "Error reading setup initialization file" on running patch


Error-7065 Windows Installer 3.1 Engine could not be found, while creating a patch On install the patch "Error reading setup initialization file" is observed.


ISDEV: Warning -7065: The Windows Installer 3.1 Engine could not be found. Please download this using the Redistributable Downloader under the Tools menu. 

Error Reading initialization file. on installing the installer created 


This Error is known to occur on our IS2022R1 version of InstallShield when creating patch or quick patch projects, the master issue number is IOK-791978.


To fix this issue, we need to copy the Windows Installer 3.1 engine to InstallShield installdir location.

To copy the Windows Installer 3.1 engine:

  1. Download attached folder.
  2. Extract the download zip file.
  3. Go to the machine where InstallShield is installed.
  4. Copy the extracted MSI3.1 folder to the i386 folder in the InstallShield installdir directory.
    For example: C:\Program Files (x86)\InstallShield\2022\Redist\Language Independent\i386

    QP msi3.1 folder copy.PNG
  5. Close InstallShield and reopen.

Now you will be able to build a Quick Patch project without error 7065.

Labels (1)
Was this article helpful? Yes No
50% helpful (1/2)

I completely DISAGREE the way you suggest the fix. Why don't you provide this fix as part of SP or HF or R1 or R2 or simple installer specific to this issue so that customers can easily install instead of doing all the manual steps. Long back I suggested the same when you people tried to give a fix in similar way , I forgot whether it is for IS or IA.

If customer needs to update on more number of machines then he/she has to do this manual drama several times on each and every machine, do you agree?



@madhug : I understand your concern, however what we suggest is an work around for now until we provide an hotfix or Service package, and we can confirm this issue is already fixed and the fix will be available as part  of our IS2022R2 builds.

And this specific issue and work around suggested is for IS2022R1 builds,

Can you tell us when R2 is going to be released. You are providing the fix and asking customers to do the manual task. Why don't you provide the VB or powershell script along with zip. User execute the script and it does the job. We generally  provide the scripts  for our customers for these kind of issues , that will make customers life easy and 100% hassle free. My main concern is if anything goes wrong while applying the manual work around on production machine we need to catch IS support and there will be downtime.

Thanks for your feedback.

IS2022R2 is planned to do release on 9th Dec 2022, if their are no last moment changes  you can expect it on time as planned.

I get this warning using IS2022R2. Is not fixed?

@grahmatian : let me check and update.

Could you please in below path you have the msi folder and file exists after installing IS2022R2,

Are you upgrading from IS2022R1 to IS2022R2 or installing IS2022R2 in a clean installation? Please confirm

C:\Program Files (x86)\InstallShield\2022\Redist\Language Independent\i386

@varul , I upgraded from R1 to R2.

I upgraded from R1 to R2 and the problem is still there. I had to add the file manually per this note.

@varul Did a clean install of InstallShield 2022 R2, also received the same error.

Hi @ashutoshgarg,


 If you are installing a IS2022R2 clean installation, you wont see the error at build time, 

And you wont see this files(msi3.1 folder) as well in language independent folder, because its already fixed to handle the error at code level.


@varul I installed using InstallShield2022R2PremierComp.exe, I had a InstallShield 2019R3 installed but dit not upgrade from 2022R1 to 2022R2. Received this error when building a Basic MSI project.

I used InstallShield2022R2PremierComp.exe setup to install, no previous 2022 version was installed, I did have InstallShield 2019 on my machine installed.I used InstallShield2022R2PremierComp.exe setup to install, no previous 2022 version was installed, I did have InstallShield 2019 on my machine installed.

Hi @ashutoshgarg,

 Are you creating a patch? or creating a BMSI project you see the error?

If you are seeing this error for BMSI project in 2022R2, I suggest to create a new support case.

Navigate to Get Support > Open New Case in the top menu and open a new case to track this issue if you would like to proceed with having this issue addressed? That will allow us to best track this issue in order to best assist you.

Please share the complete build log and the ism file while creating a case.

I upgraded from R1 to R2 and had the issue. I did not do a clean install.

But I fixed the problem by reading the IOK-791978 instructions on the web site.


Chris Wanta
Applications Engineer - Industrial Drives
Parker Hannifin Corporation
Electronic Motion & Controls Division
Charlotte, NC, USA
Drives | Parker NA<>

Hi @cjwanta,

 You are seeing this issue in Basic MSI project creation or for creating a patch?

could you please share what fixed the issue,(IOK-791978 instruction website link)

Can you please clarify where to download that zip file?

Scratch that. You can copy that folder from an older version of IS. In my case 2021. This is really clumsy and I have a hard time understanding how it passed quality control.

For the benefit of others:

Locate Programfiles(x86), under that Instalshield. Under that (if you are lucky) you have several 2018, 2020, 2021. Under any of the older, look for Redist/Languageindependent.

Copy MSI3.1 from there to corresponding folder under 2022.

Now Bob is your father's brother!

Hi @anders_gustafs,


 We are checking with the attachment missing on this specific KB article,

However could you please confirm what version of installshield you are using? IS2022R1 or IS2022R2? If you are already using IS2022R2 this specific msi file is not required any more.

Are you creating a patch?

It is R1. I was not aware that there was an R2 and some of the comments above indicate that the issue persists in R2 also. Yes, we are creating a Quickpatch for a product we released in January.

I have now downloaded and installed R2. Is there anything else I need to do? The quickpatch builds without issues, but then again have I copied the files manually

Hi @varul  I have freshly installed IS2022R2 but still the issue is there.
Is this Fixed in IS2022R2?
Can you please help on this?

Hi @Sattibabu 

 What is your project type? Basic MSI?

Is your project release --> setup.exe tab --> include msi engine set to YES. 

If it set to YES change it to NO and then try again, 

And we have this issue fixed in our IS2023R1, You can refer below release notes for issue number "ISDEV-42950" include msi engine.png

Hi @varul 

  • When we added “No” in Media--Releases--setup.exe tab--Include MSI engine, it’s breaking the basic functionality of an installer(Giving following error shown below). We are not able to install any package which is build using the setting Option “No”.
    • ERROR: error reading setup initialization file
  • If we add these MSI3.1 in installshield location, it will be the tedious task for every developer.
  • Is this warning there earlier? 
  • When we set to YES , why Jenkins build is failing with this warning?

Please provide update.



Hi @Sattibabu ,

If you upgrade to IS2023R1 or R2 you are still seeing this issue? since this issue is fixed in our IS2023R1, Please upgrade and then try once.

 Are you able to see the setup installation error on test project as well, meaning if you create a test project with "No" option on installing you are seeing the error 

  • ERROR: error reading setup initialization file

If yes, I suggest you to please raise a case and add your  issue description and our support engineering will be able to assist further on this issue,

Hi @varul  I have freshly installed IS2022R2, still getting the same windows 3.1 installer issue and if I set the engine to No, then I am getting the below error.

  • ERROR: error reading setup initialization file

why it's treating as error in jenkins?

is this warning existed earlier? and what is the use of windows 3.1 installer?

please provide answers for my questions and I will be opening Case as well.



Hi @varul 

we have upgraded to IS2023R2 and build is successful but when launching the setup.exe we are getting the below error. Can you please help on this?

  • ERROR: error reading setup initialization file
Version history
Last update:
‎Jun 21, 2023 01:53 PM
Updated by: