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Warning-7065 Windows Installer 3.1 Engine could not be found, while creating a patch and "Error reading setup initialization file" on running patch

Warning-7065 Windows Installer 3.1 Engine could not be found, while creating a patch and "Error reading setup initialization file" on running patch

Summary:

Error-7065 Windows Installer 3.1 Engine could not be found, while creating a patch On install the patch "Error reading setup initialization file" is observed.

Symptoms:

 

 

 

 ISDEV: warning -7065: The Windows Installer 3.1 Engine could not be found. Please download this using the Redistributable Downloader under the Tools menu. 

Error Reading initialization file. on installing the installer created 

 

 

 

Cause:

This Error is known to occur on our IS2022R1 version of installshield when creating patch or quick patch projects,  the master issue number is IOK-791978 

Resolution:

To fix this issue, we need to copy windows installer 3.1 engine to installshield installdir location, 

  1. Download attached MSI3.1.zip folder 
  2. Extract the download zip file
  3. Go to machine where Installshield is installed
  4. Then copy extracted Msi3.1 folder to installshield installdir i386 folder
  5. EX: C:\Program Files (x86)\InstallShield\2022\Redist\Language Independent\i386QP msi3.1 folder copy.PNG
  6. Close installshield and Reopen

  7. Now we will be able to build Quick Patch project without error 7065.

 

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Comments

I completely DISAGREE the way you suggest the fix. Why don't you provide this fix as part of SP or HF or R1 or R2 or simple installer specific to this issue so that customers can easily install instead of doing all the manual steps. Long back I suggested the same when you people tried to give a fix in similar way , I forgot whether it is for IS or IA.

If customer needs to update on more number of machines then he/she has to do this manual drama several times on each and every machine, do you agree?

 

 

@madhug : I understand your concern, however what we suggest is an work around for now until we provide an hotfix or Service package, and we can confirm this issue is already fixed and the fix will be available as part  of our IS2022R2 builds.

And this specific issue and work around suggested is for IS2022R1 builds,

Can you tell us when R2 is going to be released. You are providing the fix and asking customers to do the manual task. Why don't you provide the VB or powershell script along with zip. User execute the script and it does the job. We generally  provide the scripts  for our customers for these kind of issues , that will make customers life easy and 100% hassle free. My main concern is if anything goes wrong while applying the manual work around on production machine we need to catch IS support and there will be downtime.

Thanks for your feedback.

IS2022R2 is planned to do release on 9th Dec 2022, if their are no last moment changes  you can expect it on time as planned.

I get this warning using IS2022R2. Is not fixed?

@grahmatian : let me check and update.

Could you please in below path you have the msi folder and file exists after installing IS2022R2,

Are you upgrading from IS2022R1 to IS2022R2 or installing IS2022R2 in a clean installation? Please confirm

C:\Program Files (x86)\InstallShield\2022\Redist\Language Independent\i386

@varul , I upgraded from R1 to R2.

I upgraded from R1 to R2 and the problem is still there. I had to add the file manually per this note.

@varul Did a clean install of InstallShield 2022 R2, also received the same error.

Hi @ashutoshgarg,

 

 If you are installing a IS2022R2 clean installation, you wont see the error at build time, 

And you wont see this files(msi3.1 folder) as well in language independent folder, because its already fixed to handle the error at code level.

 

@varul I installed using InstallShield2022R2PremierComp.exe, I had a InstallShield 2019R3 installed but dit not upgrade from 2022R1 to 2022R2. Received this error when building a Basic MSI project.

I used InstallShield2022R2PremierComp.exe setup to install, no previous 2022 version was installed, I did have InstallShield 2019 on my machine installed.I used InstallShield2022R2PremierComp.exe setup to install, no previous 2022 version was installed, I did have InstallShield 2019 on my machine installed.

Hi @ashutoshgarg,

 Are you creating a patch? or creating a BMSI project you see the error?

If you are seeing this error for BMSI project in 2022R2, I suggest to create a new support case.

Navigate to Get Support > Open New Case in the top menu and open a new case to track this issue if you would like to proceed with having this issue addressed? That will allow us to best track this issue in order to best assist you.

Please share the complete build log and the ism file while creating a case.

I upgraded from R1 to R2 and had the issue. I did not do a clean install.

But I fixed the problem by reading the IOK-791978 instructions on the web site.

Regards

[cid:image001.jpg@01D94C27.FAADCCF0]
Chris Wanta
Applications Engineer - Industrial Drives
Parker Hannifin Corporation
Electronic Motion & Controls Division
Charlotte, NC, USA
Drives | Parker NA<>

Hi @cjwanta,

 You are seeing this issue in Basic MSI project creation or for creating a patch?

could you please share what fixed the issue,(IOK-791978 instruction website link)

Version history
Last update:
‎Dec 08, 2022 02:51 AM
Updated by:
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