cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
AndrewW
Flexera beginner

isdbg.exe (IS2016 PROFESSIONAL EDITION) not debugging remotely

I'm trying to debug an Installshield script remotely, by running setup.exe /d"<Path to .dbg file>"

I'm running InstallShield 2016 Professional Edition, Version 23, Service Pack 2.

However, I get the message "Failed to create empty document".

1) I've copied across the SciLexer.dll and it's in the same directory as isdbg.exe

2) I've installed the VC++ 2012 redistributable, as per the notes in the Installshield help.

Any ideas why this is happening?

 

 

 

0 Kudos
4 Replies
AndrewW
Flexera beginner

Re: isdbg.exe (IS2016 PROFESSIONAL EDITION) not debugging remotely

Thanks for the information. However, these links actually raise more questions than answers.

I have a few questions arising from the article:

https://community.flexera.com/t5/InstallShield-Knowledge-Base/Debugging-a-Setup-on-a-Test-Machine/ta...

1. The registry key HKEY_CLASSES_ROOT\Setup.ScriptDebugger does not exist in my system even after I run isdbg.exe /REGSERVER. Why is this so?

2. The last update of this document was December 3, 2007, but I'm using Installshield 2016. Is this document up to date?

3. I've done all the steps outlined in this document. I've copied across isdbg.exe and sciLexer.dll. I've registered isdbg.exe with /REGSERVER. I've installed the VC++ 2012 Redistributable. I copied all the files into a single directory c:\temp. And yet still I get the same error message. Is the problem that the tool is not registered properly (see question 1)? Or is there something else you can point me towards?

Kind Regards,

AndrewW

 

0 Kudos
MarkusLatz
Intrepid explorer

Re: isdbg.exe (IS2016 PROFESSIONAL EDITION) not debugging remotely

You have to open a "cmd" window with "Run as Administrator",  there try to register isdbg.exe

regards

Markus

0 Kudos
AndrewW
Flexera beginner

Re: isdbg.exe (IS2016 PROFESSIONAL EDITION) not debugging remotely

I ran the cmd as an administrator, and tried registering the debugger again. There is still no registry key HKEY_CLASSES_ROOT\Setup.ScriptDebugger.

Note: the debugger does appear, but gives the error "Failed to Create Empty Document".

Any other ideas on why this is not working?

Regards,

Andrew

0 Kudos