cancel
Showing results for 
Search instead for 
Did you mean: 
1shoke1
Flexera beginner

Way to inform user they don't have admin privileges

I have a suite installation with various packages, all but the prereq one requires elevated privileges. However if a non admin user tries to run the installer it doesn't report anything. It just skips to the end dialog. What would be the best way to get the message across?
Labels (1)
0 Kudos
6 Replies
Jamesbo
Pilgrim

Re: Way to inform user they don't have admin privileges

I would just make the installer require admin privileges. This would prompt them to login as an admin if they are not, and should make it obvious it is necessary.

Under "General Information" under "Summary Information Stream" set "Require Administrative privileges" to "yes".
I think you will also want (if using Setup.exe) to set in "Releases" -> "Product Config" -> "Release 1" -> "Setup.exe" tab -> "Required Execution Level" to "Administrator"
0 Kudos
Highlighted
1shoke1
Flexera beginner

Re: Way to inform user they don't have admin privileges

Jamesbo wrote:
I would just make the installer require admin privileges. This would prompt them to login as an admin if they are not, and should make it obvious it is necessary.

Under "General Information" under "Summary Information Stream" set "Require Administrative privileges" to "yes".
I think you will also want (if using Setup.exe) to set in "Releases" -> "Product Config" -> "Release 1" -> "Setup.exe" tab -> "Required Execution Level" to "Administrator"



Thanks but we've already done that. It still doesn't ask or prevent them from running it, it just behaves as I explained.
0 Kudos
DataAnalyzer
Pilgrim

Re: Way to inform user they don't have admin privileges

I'm having the same problem. Wondering if there's a solution.

Even asking the user to right click and Run as Administrator isn't elevating the level.

I try to set ALLUSERS = 1, but it doesn't change it from 0 so I can tell it's not running as Administrator. Not sure why selecting Run as Administrator doesn't work either..
0 Kudos
MattQVI
Active participant

Did you check the UAC level?

The UAC level might be affecting this. If it's set to Never Notify - you wouldn't know that it's being elevated. If you check the system you are trying to install on and it is the lowest level. Try changing it to one above the lowest.
0 Kudos
DataAnalyzer
Pilgrim

Re: Way to inform user they don't have admin privileges

Where is the setting for Never Notify? Is that at the machine or user level?

Part of the reason to have the setup program is so that it handles whatever settings the user has since we can't control/see that until we install ourselves.
0 Kudos
MattQVI
Active participant

Re: Way to inform user they don't have admin privileges

Change User Account Control Settings (UAC) so probably the user level? From the Start menu, you should be able to type UAC to launch it. If the slider is at the bottom, it would be set to Never Notify.
0 Kudos