cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Flexera beginner

Setup.exe fails to starts on Windows 10 Pro having version 1909

Initializing window does not appears on the screen, when launch on Windows 10 Pro with version 1909.

Same installer works fine with lower version. 

0 Kudos
6 Replies
Highlighted
Revenera
Revenera

Re: Setup.exe fails to starts on Windows 10 Pro having version 1909

You can try and get some more information as to what is happening here by running some logs:

You can log the setup.exe bootstrapper by using the command:
Setup.exe /debuglog"C:\PathToLog\setupexe.log"

You can log the Windows Installer Engine by following these instructions:
https://support.microsoft.com/en-gb/help/223300/how-to-enable-windows-installer-logging 

Hopefully one of these logs will provide more information as to what the problem is.

0 Kudos
Highlighted
Flexera
Flexera

Re: Setup.exe fails to starts on Windows 10 Pro having version 1909

Hi @shriramcs ,

 

An update in addition to @shunt  s reply:

I had tried this from my end:Setup built up of Installshield 2018 express on 1909 Pro works fine.

  • Is it reproducible on all the Windows 10 1909 Pro machines?
  • Better to attach log here for more information.

Thanks,

Jenifer

0 Kudos
Highlighted
Occasional contributor

Re: Setup.exe fails to starts on Windows 10 Pro having version 1909

I have the same problem. Several of my clients experience this issue. My intuition tells me that it has to do something with the prerequisites. For example, one of my prerequisites include Microsoft .NET Framework 4.7.2. One thing to notes is that Windows 10 Pro 1909 targets only .NET Framework 4.8. This may be causing the installer to come to a halt, as it cannot install .NET Framework 4.7.2 on Windows 10 Pro 1909. 

0 Kudos
Highlighted
Occasional contributor

Re: Setup.exe fails to starts on Windows 10 Pro having version 1909

However, I am unsure, as the installer does not throw a dialogue error. Work around is just grabbing the .msi file and installing directly on the computer.
Highlighted
Flexera beginner

Re: Setup.exe fails to starts on Windows 10 Pro having version 1909

As fails at initialization  dialog  so nothing gets added in log file.

 

0 Kudos
Flexera
Flexera

Re: Setup.exe fails to starts on Windows 10 Pro having version 1909

Hi @standardsdesign ,

 

If you are sure about .NET framework been added causing the issue,can you uncheck that specific pre-requisite and try building the setup?If any of the payload has dependency with .NET prq been removed,please remove that as well for verification purposes?

This can help us with further guidance on this matter.

 

Thanks,

Jenifer

0 Kudos