cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
balaji_ayyanar
Flexera beginner

How to make installer to install earlier version

Jump to solution

Hi,

in an install script project, how can we let the installer to install earlier version than installed version (a) how to make an installer to downgrade? I am stuck with a pop-up saying "This setup installs an earlier version"

Thanks,.

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
Flexera Jenifer
Flexera

Re: How to make installer to install earlier version

Jump to solution

Hi @balaji_ayyanar ,

 

When you click on Setup.Rul,you will be able to see two combo-boxes where you can select methods in the editor window.

  • On first combobox select "Before Move Data"
  • On select combobox select "OnUpdateUIBefore"
  • Comment out the below lines:
  • // Check whether the update is older than the currently installed version.
    if( nResult = VERSION_COMPARE_RESULT_OLDER ) then
    szMsg = SdLoadString( IDS_IFX_ERROR_UPDATE_NOT_APPROPRIATE );
    SdSubstituteProductInfo( szMsg );
    MessageBox( szMsg, SEVERE );
    abort;
    endif;//

Then try out,it will work.I had verified this been working.

 

Thanks,

Jenifer

View solution in original post

3 Replies
Highlighted
Flexera Jenifer
Flexera

Re: How to make installer to install earlier version

Jump to solution

Hi @balaji_ayyanar ,

 

You can achieve setup downgrade by commenting/removing below lines of code from OnUpdateUIBefore event:The specific event you can find under:

Behavior and Logic->InstallScript->Setup.rul->Before Move Data->OnUpdateUIBefore

// Check whether the update is older than the currently installed version.
//if( nResult = VERSION_COMPARE_RESULT_OLDER ) then
// szMsg = SdLoadString( IDS_IFX_ERROR_UPDATE_NOT_APPROPRIATE );
// SdSubstituteProductInfo( szMsg );
// MessageBox( szMsg, SEVERE );
// abort;
//endif;

 

Hope it helps,

Thanks,

Jenifer

0 Kudos
Highlighted
balaji_ayyanar
Flexera beginner

Re: How to make installer to install earlier version

Jump to solution
There is no such Event like "OnUpdateUIBefore" on Setup.rul Is there any other way ?
0 Kudos
Flexera Jenifer
Flexera

Re: How to make installer to install earlier version

Jump to solution

Hi @balaji_ayyanar ,

 

When you click on Setup.Rul,you will be able to see two combo-boxes where you can select methods in the editor window.

  • On first combobox select "Before Move Data"
  • On select combobox select "OnUpdateUIBefore"
  • Comment out the below lines:
  • // Check whether the update is older than the currently installed version.
    if( nResult = VERSION_COMPARE_RESULT_OLDER ) then
    szMsg = SdLoadString( IDS_IFX_ERROR_UPDATE_NOT_APPROPRIATE );
    SdSubstituteProductInfo( szMsg );
    MessageBox( szMsg, SEVERE );
    abort;
    endif;//

Then try out,it will work.I had verified this been working.

 

Thanks,

Jenifer

View solution in original post