cancel
Showing results for 
Search instead for 
Did you mean: 

Error -3204: Cannot extract icon with index 0 from file

Hi,

I'm using IS 2013 LE. The icon file I'm using for my shortcuts is the standard IS setup.ico that ships with IS and is located in
\redist\Language Independent\OS Independent\setupicon.ico

I did this to remove the possibility that the problem I'm seeing is being caused by my own icon file.

The build fails about 30% of the time with this error.
C:\Program Files (x86)\MSBuild\InstallShield\2013Limited\InstallShield.targets(108, 3): -3204: Cannot extract icon with index 0 from file C:\TeamCity\buildAgent\work\258316e5d2bb2bf4\icon.ico.

It fails from the IDE and from MSBUILD. I also get random exception crashes like the following...
c:\Program Files (x86)\MSBuild\InstallShield\2013Limited\InstallShield.targets(108, 3): Exception Caught

This happens on our build machine and 2 other developer machines. All with the same random occurrence.

What is the method I can use to debug and resolve this?

Jeff.
0 Kudos
4 Replies
Flexera Ken536
Flexera

Re: Error -3204: Cannot extract icon with index 0 from file

Hello Jeff,

Are you using your own icon in the Add or Remove Program section of the General Information view?
0 Kudos

Re: Error -3204: Cannot extract icon with index 0 from file

kyi wrote:
Hello Jeff,

Are you using your own icon in the Add or Remove Program section of the General Information view?


Yes, but I'm using the Flexera supplied "setupicon.ico".
0 Kudos

Re: Error -3204: Cannot extract icon with index 0 from file

Is there anyone who can help with this error?

Thanks,

Jeff.
0 Kudos
Flexera Ken536
Flexera

Re: Error -3204: Cannot extract icon with index 0 from file

Hi Jeff,

Can you provide the project or a sample project that is displaying the behavior?
Also, for the inconsistency in the error, do you have a anti-virus program active in your network? If yes, is it possible to disable it for testing?
0 Kudos