MattQVI
Active participant

Empty Support URL in the IS project is actually getting the path to the ReadMe file - WHY!?

In my Basic MSI install using InstallShield 2015 Pro, the Support URL has been cleared out because of an internal company disagreement as to what it should point to.  So until that is worked out, I was asked to leave it blank/empty.  Unfortunately, when I built the install on 6/7/2020 -- it now contained the path to the ReadMe file.

Did I just find a bug?  Or is there something else in the DirectEditor or strings that needs to be cleared out?  It's empty in the project so this does seem like a bug.

Thanks for your help.

Labels (1)
0 Kudos
19 Replies
Jenifer
Flexera Alumni

Hi @MattQVI ,

 

When you say "the Support URL has been cleared out" can you please elaborate?How did you clear that out?

 

Precise details will always allow us to help you on time.

 

Thanks,

Jenifer

0 Kudos
MattQVI
Active participant

Cleared out:  I highlighted the link that I originally typed in and pressed the Delete key.  Now the field reads (in a light grey) "Example: http://www.my_company_name.com/support" and when I click in the field - it's empty like I want it to be.  But after installing, the Support URL is the path to the ReadMe file.

0 Kudos

Hi @MattQVI ,

 

Got it!!Thanks for the quick response.

 

Can you check ARPHELPLINK property under Property table using Direct Editor view?That is the one responsible for saving Support URL property.

Below link can talk in detail about various properties of Add/Remove Programs(ARP):

https://docs.flexera.com/installshield26helplib/helplibrary/IHelpPropReference.htm

 

Hope it helps,

Thanks,

Jenifer

0 Kudos
MattQVI
Active participant

There is no ARPHELPLINK record in Property under Direct Editor.  Should I add one and leave it blank?

 

ARPInfoIS.PNG

0 Kudos

Hi @MattQVI ,

 

Unfortunately i couldn't reproduce the issue with InstallShield 2015 SP2(With Basic MSI project),no need to add property with empty value.Since on having empty value it will remove the property from table.

 

Can you send us snap of ARP details on selecting installed software?

 

 

Thanks,

Jenifer

0 Kudos
MattQVI
Active participant

addRemoveSnip.PNG

0 Kudos
MattQVI
Active participant

myProjectSnip.PNG

0 Kudos
MattQVI
Active participant

The first one is our product in Add/Remove Programs.  The Help link is pointing to the ReadMe.

The second one is my project.  The Support URL is empty.

 

0 Kudos
MattQVI
Active participant

So why if my Support URL is empty it is getting the path the ReadMe instead?  It looks like a bug.

0 Kudos
MattQVI
Active participant

It's been almost two weeks since my last post on this issue.  I followed up showing the contents of the Help Link in the InstallShield project (it's empty) and the fact that it's pointing to the Read Me file in the Control Panel's Programs and Features for my application.

Why is the Support Link displaying the wrong value?

0 Kudos

Hi @MattQVI ,

Thanks for your interest on improving product quality of InstallShield. Took some time to figure it out.

  • Few registry keys to be remembered on this regard:

    Property Name

    Microsoft's property  InstallShield's UI interpretation
    HelpLink ARPHELPLINK property- Support URL
    URLInfoAbout ARPURLINFOABOUT property Publisher/Product URL
    URLUpdateInfo ARPURLUPDATEINFO property Product Update URL
    Comments ARPCOMMENTS property
    Comments provided to the Add or Remove Programs control panel.
    ARP Comments
    Readme ARPREADME property
    Readme provided to the Add or Remove Programs control panel.
    ReadMe
  • You can see these values getting saved under registry key path:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\<Application's Product GUID>

  • On leaving Support URL empty and keeping read me ,registry values get set properly.
  • But Microsoft ARP displays the property URLInfoAbout's value in Help Link if it has value else Read Me property's value.
  • Had verified this few other installer tools as well,same behavior.

Looks like it isn't a bug,that is the way ARP deals with installers.

 

Thanks,

Jenifer

0 Kudos
MattQVI
Active participant

You can see from a different project which does not contain Support URL or Readme that it still gets the ReadMe path! 

0 Kudos
MattQVI
Active participant

0 Kudos
MattQVI
Active participant

0 Kudos
MattQVI
Active participant

 
0 Kudos
MattQVI
Active participant

 
0 Kudos
MattQVI
Active participant

Here's the General INformation from that project.  Notice the Read Me path is empty -- yet it's still getting populated.

0 Kudos
MattQVI
Active participant

ARP information from the Property table contains nothing for Support URL or Read Me.

0 Kudos

Hi @MattQVI ,

 

Thanks for reporting the issue related with emptying readme doesn't update in ARP.

We've raised an issue with engineering which can be tracked with the ID "IOJ-2125002".This will be addressed in the future release of Installshield .

 

Thanks,

Jenifer

0 Kudos