Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 4

Access Denied when installing

I have built this installer before, and I have installed it successfully when testing. Currently, it won't install on my machine due to an "Access Denied" error for the "C:\Program Files (x86)\InstallShield Installation Information\{GUID}" folder. I am an administrator on my machine. When I try to manually delete the folder, I get an error that it requires administrator privileges. I have deleted other folders in "C:\Program Files (x86)\InstallShield Installation Information" without a problem. I have ended all tasks that appeared to be hanging up this folder. The folder contains only the setup.exe file. When I try to delete that file, I still have the problem.

I've tried changing permissions on the folder, and adding my current username specifically, rather than just the Administrators group, and giving myself full control. It gave me an error when setting permissions, but still lists me as having full control. Yet it still won't allow me to delete the folder.

I've tried opening a command window using "Run as administrator," and then executing "rmdir /s" on the folder. No luck. "Access Denied."

What is going on here?
Is this a bug?
This started happening after another unrelated program installation deleted my system path. I've added back everything I think I need. Is there something that should be in my path for InstallShield?
Is there something else that is hung that I should kill in my task manager?
Is there a problem with the uninstallation, where this folder is being left behind, or being locked? Do I need to add something else to my InstallScript to prevent that?

Previously, I was able to install after restarting my computer. If one of my users experiences this it is unacceptable, so I need to figure out what the problem is.

Labels (1)
0 Kudos
(1) Reply
Level 4

If you care to know, the thing that erased my system path was installing the NetCDF libraries from Unidata UCAR. If you select the option to add it to your path, it erases your whole path, leaving only the NetCDF tools in the path, at least on Windows 10.
0 Kudos