cancel
Showing results for 
Search instead for 
Did you mean: 
Superfreak3
Occasional contributor

1334 Error - Anyone Know Any Obscure Cures?

Hi all,

All of a sudden our web app installation is erroring with a 1334 - file cannot be found in .cab file. We are currently using InstallShield 2018 SP1. I've tried everything I can think of or found online, but I just can't get past this error.

I've removed the problematic component to see if it was some type of file problem, but the error just moved on to another file in the installation. Removed that, error just moved on to different file.

I even compiled a previous, released version which hasn't been touched in weeks and it errored on the same exact file. The source files for that release are in a completely different location, of course, than the originally failing release. My thought was maybe the source files were on a bad area of disk or something like that. That led me to believe that it might be something with InstallShield itself that went awry, .dll, a configuration setting or something like that. I repaired our InstallShield instance, no luck.

Ran chkdsk, no luck.

I've tried different compression settings in the Release settings, no luck.

I tried adding a different Release configuration, no luck.

I tried moving the .ism project directory, no luck.

I sent the build log and .ism to InstallShield support and they didn't see anything out of the ordinary there. They said they've seen this error with weird or missing file dates, but that is no the case here.

Does anyone know what else I could try? Any obscure cures?

Info MUCH Appreciated!!
Labels (1)
0 Kudos
10 Replies
Flexera Jenifer
Flexera

Re: 1334 Error - Anyone Know Any Obscure Cures?

Superfreak3 wrote:
Hi all,

All of a sudden our web app installation is erroring with a 1334 - file cannot be found in .cab file. We are currently using InstallShield 2018 SP1. I've tried everything I can think of or found online, but I just can't get past this error.

I've removed the problematic component to see if it was some type of file problem, but the error just moved on to another file in the installation. Removed that, error just moved on to different file.

I even compiled a previous, released version which hasn't been touched in weeks and it errored on the same exact file. The source files for that release are in a completely different location, of course, than the originally failing release. My thought was maybe the source files were on a bad area of disk or something like that. That led me to believe that it might be something with InstallShield itself that went awry, .dll, a configuration setting or something like that. I repaired our InstallShield instance, no luck.

Ran chkdsk, no luck.

I've tried different compression settings in the Release settings, no luck.

I tried adding a different Release configuration, no luck.

I tried moving the .ism project directory, no luck.

I sent the build log and .ism to InstallShield support and they didn't see anything out of the ordinary there. They said they've seen this error with weird or missing file dates, but that is no the case here.

Does anyone know what else I could try? Any obscure cures?

Info MUCH Appreciated!!


Hi,

When you say web app installation is it via Suite project or something else?

Can you please attach complete log file here to check for more updates?


Thanks,
Jenifer
0 Kudos
Superfreak3
Occasional contributor

Re: 1334 Error - Anyone Know Any Obscure Cures?

Jenifer wrote:
Hi,

When you say web app installation is it via Suite project or something else?

Can you please attach complete log file here to check for more updates?


Thanks,
Jenifer


It is a Basic .msi package wrapped in a Setup.exe, which also delivers prerequisites. The install log is attached in two parts.

I've sent the log to InstallShield and they indicated they saw no problems other than the 1334 error.
0 Kudos
rguggisberg
Active participant

Re: 1334 Error - Anyone Know Any Obscure Cures?

Maybe try revoking your InstallShield License and install InstallShield on another machine?
0 Kudos
Superfreak3
Occasional contributor

Re: 1334 Error - Anyone Know Any Obscure Cures?

rguggisberg wrote:
Maybe try revoking your InstallShield License and install InstallShield on another machine?


Yep, that's what I'm working on now. I was wondering if the trial version of IS is fully functional or has limitations. I don't want to revoke the license and install on another machine because other things are building fine on that production server.

I wonder if a complete uninstall/reinstall would do the trick. If so, do I have to revoke the license if working on the same machine.
0 Kudos
rguggisberg
Active participant

Re: 1334 Error - Anyone Know Any Obscure Cures?

Let us know how that all works out for you.
Also, be careful how many times you revoke and re-use the license. After a few times you may have to contact Flexera.
0 Kudos
Superfreak3
Occasional contributor

Re: 1334 Error - Anyone Know Any Obscure Cures?

rguggisberg wrote:
Let us know how that all works out for you.
Also, be careful how many times you revoke and re-use the license. After a few times you may have to contact Flexera.


Will do. Before I go the revoke route, I'm hoping I can use the trial to see if things work out on another machine. The only problem is, when I download the installer and install on different machine, when I launch IS, I can't select the option to continue with evaluation. I can only select activate or get license from server. I guess it sees a paid, running instance on the network.
0 Kudos
Superfreak3
Occasional contributor

Re: 1334 Error - Anyone Know Any Obscure Cures?

I was able to get an instance of the trial version of InstallShield up and running on a new machine. The problem persists even if compiled on a different machine. So, the problem must be project specific.

The strange thing is that are released version is bad if recompiled and that hasn't been touched since release. Also, if a pull an install template from a few days prior and compile that too is problematic. This is perplexing and probably going to kill me! :confused:
0 Kudos
rguggisberg
Active participant

Re: 1334 Error - Anyone Know Any Obscure Cures?

Maybe try installing InstallShield on an older OS???
0 Kudos
Superfreak3
Occasional contributor

Re: 1334 Error - Anyone Know Any Obscure Cures?

rguggisberg wrote:
Maybe try installing InstallShield on an older OS???


What do you think that will do? It's been working fine. But I get it, who the heck knows what it might be.

Come to think of it, the trial version was run on an older OS.
0 Kudos