cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Flexera beginner

Installers can't be executed on latest versions of Mac OS X, problem with permissions

Hello,

We see this problem on the latest OS X version (Catalina 10.15.2 ).  We tested it on 2 Mac machines.

Symptoms: The installation process is not launched.

"The application “InstallerName.app” can’t be opened." alert displayed.

However, the same installer works correctly on previous versions of OS X. 

 

We found that this problem caused by wrong permissions on InstallerName.app/Contents/MacOS/InstallerName. The latest OS X version requires the execution permission. Old versions of OS X do not require this permission to run the application.

Fix: unzip the installer manually, add execution permission to that file, zip it again.

 

We use InstallAnywhere 2018 on the Windows platform to create all installers.

Is there any chance to fix it in IS Anywhere updates?

0 Kudos
1 Reply
Highlighted
Flexera beginner

Re: Installers can't be executed on latest versions of Mac OS X, problem with permissions

Hi, 

This permission issue is specific to MAX OSX Catalina version. Fix will be available in InstallAnywhere2021 release.

Workaround provided will make sense because, you are building installer in windows platform and Apple is making codesign and Notarization of any app outside App store mandatory. So app built on windows needs to taken to Mac platform and unzip, codesign and notarization needs to be done manually and then again zip the installer. So until fix is available you need to manage with the workaround.

0 Kudos