cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Intrepid explorer

Three items related to Download Package maintenance, general polling question, detecting expired line item with code

Jump to solution

Good afternoon! I have three questions:

1) Can a download package associated with a product be deleted, ignored  or possibly modified? We see a situation where the "to" download package in an upgrade may need to be modified over time. When new software is available a "from" package will have a new "to" version. I can change the contents of a file, but that seems like a kludge.

2) When there is first a Post and then polling get operation, (like with updates) is the original polling id always good to retry, for polling again if the first polling try returns 202. It seems to be, but one time I wasn't sure.

3) Is there any way to tell the difference using the Web API to see if the line item expiration date related to an entitlement expired. I notice that 0 update are available using the Web API. However when I try a "from" package from an update that does not exist, I also see that 0 updates are available. Is there a way to tell the difference between these two conditions .

 

 

0 Kudos
1 Solution

Accepted Solutions
Revenera Moderator Revenera Moderator
Revenera Moderator

Re: Three items related to Download Package maintenance, general polling question, detecting expired line item with code

Jump to solution

Hi Ken,

Sorry but true.  We have FNO web services that can be used to query entitlements to get that information however they require username and password for authentication and are typically used for back office integration.

Thanks,
Jim

 

View solution in original post

4 Replies
Revenera Moderator Revenera Moderator
Revenera Moderator

Re: Three items related to Download Package maintenance, general polling question, detecting expired line item with code

Jump to solution

Hi Ken,

1)  If I understand your question you have a Download Package v1.0 the is currently being updated to v1.1.  At some later point in time you wish to update customers running v1.0 to v1.11.  You can add the v1.11 download package (and associate it to the desired Product if you are doing an Entitlement based check) and then edit the Update, replacing the v1.1 To download package with v1.11.  You may also want to add v1.1 to the "From" Download Package in the Update so that if a device is running either v1.0 or v1.1 they will be updated to v1.11.

2) Yes, if you get a 202 response the request is still being processed.  You keep polling with the original polling ID until you get a valid response.

3) Currently with the Update request there is no way to distinguish between an expired entitlement and no available update.  I'd recommend submitting a support ticket for an enhancement request.

Thanks,

Jim

Intrepid explorer

Re: Three items related to Download Package maintenance, general polling question, detecting expired line item with code

Jump to solution

Hi Jim,

Thank you for the great response as always! Is it correct to say that there is currently no alternative way,  to check if all if the line items/maintenance items have expired for an entitlement?

Thank you,

Ken

0 Kudos
Revenera Moderator Revenera Moderator
Revenera Moderator

Re: Three items related to Download Package maintenance, general polling question, detecting expired line item with code

Jump to solution

Hi Ken,

Sorry but true.  We have FNO web services that can be used to query entitlements to get that information however they require username and password for authentication and are typically used for back office integration.

Thanks,
Jim

 

View solution in original post

Intrepid explorer

Re: Three items related to Download Package maintenance, general polling question, detecting expired line item with code

Jump to solution

Thank you!

0 Kudos