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Summary

Importing a License in FlexNet Manager Suite fails while using the Activation Wizard.

Symptoms

When trying to import a FlexNet Manager Suite license file, the Activation Wizard shows a "There was an error importing the license. Please contact Flexera Support for assistance" error message.

The Details section of the dialog shows an error like the following:
---Problem---

(s0m0): There was an error importing the license. Please contact Flexera Support for assistance.

---System exception---

Cannot write to queue; the current user may not have sufficient permissions, or the host address may be incorrect. Queue address: FormatName:DIRECT=OS:win-gdc-2018r1.flexdemo.local\private$\fnmsBatchProcessIncoming

---Source---

Flexera.Common.MessageQueue

---Stack trace---

Flexera.MessageQueue.MessageQueueInitializationException: Cannot write to queue; the current user may not have sufficient permissions, or the host address may be incorrect. Queue address: FormatName:DIRECT=OS:win-gdc-2018r1.flexdemo.local\private$\fnmsBatchProcessIncoming
at Flexera.MessageQueue.Microsoft.MicrosoftQueueBase`1.OpenQueue(QueueAccessMode mode)
at Flexera.MessageQueue.Microsoft.MicrosoftQueueBase`1.Open(QueueAccessMode openMode)
at Flexera.MessageQueue.Microsoft.MicrosoftQueueBase`1.GetQueue()
at Flexera.MessageQueue.Microsoft.MicrosoftQueuePublisher`1.WriteMessage(T messageBody)
at Flexera.LicenseManagement.Impl.LicensingLogic.<>c__DisplayClass10.<InitiateBatchProcessesForNewTenant>b__f(String _, ITenantInfo __)
at Flexera.Broker.Connections.Impl.TenantActions.WithTenant(ITenantInfo tenant, ConnectionType type, Action`2 tenantAction)
at Flexera.LicenseManagement.Impl.LicensingLogic.UpdateTenantLicense(String tenantUID, String companyName, String tenantDomain, String encodedLicense)
at ManageSoft.Activation.ActivationController.UpdateTenantLicense(String groupName, LicenseDetailsInstance newLicense, Byte[] rawLicense, TenantSecurityInfo currentTenant, Boolean tenantCreationMode, TenantSecurityInfo& newTenant)
at ManageSoft.Activation.ActivationWiz.ProcessLicenseFull(String p_LicenseFileLocation)
at ManageSoft.Activation.NoticePage.m_ImportLicenseBtn_Click(Object sender, EventArgs e)

Cause

The user running the Activation Wizard does not have proper access to the Microsoft Messagging Queue (MSMQ).
The users that are given access by default to the MSMQ are the Service Account and the account used to run the PowerShell script during installation/upgrade of FlexNet Manager Suite.

Resolution

Validate that the following are true:
  1. The user running the Activation User is either the Service Account, or the user that last ran the PowerShell script to install/upgraded FNMS
  2. The user has Admin rights to the Application Server
  3. The user has access to the FNMSCompliance Database (or equivalent naming convention)
The FlexNet Manager Suite installation documents mentions the following when running the Activation Wizard to import your License "Continue this process as administrator (fnms-admin), on the appropriate server (the one that includes the batch server):"

Workaround

If you can't use either of the above user accounts, then you can also replace these users by running the Config.ps1 PowerShell script with the same parameters using the FlexNet Manager Suite Upgrade Guide.
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Version history
Last update:
‎Jun 08, 2018 02:06 AM
Updated by: