cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Flexera Integration with ServiceNow - Ports and Logs

Jump to solution

Hi, we are in the midst of integrating FNMS with ServiceNow using the Flexera Integration for ServiceNow module. 

So far we have been able to set up the connection by following Flexera Docs.  Unfortunately the first export returned with Connection Failure  on the FNMS - System Settings page. I suspect that the port is blocked, so I need to allow it in firewall. 

But, I could not find what port is being used for this integrations, anyone could shed some lights here?

Also where can I find detail log of the export? The Last Completed status in System Settings does not give much of an idea. 

Thank you. 

1 Solution
lajanakiram
Level 4 Flexeran
Level 4 Flexeran

Hi @onazlie ,

For FNMS to ServiceNow export, you should find the default log location on App Server in c:\temp\log , there is no specific port as far as I'm aware, however should communicate over port 80 or 443 for http and https.

View solution in original post

2 Replies
lajanakiram
Level 4 Flexeran
Level 4 Flexeran

Hi @onazlie ,

For FNMS to ServiceNow export, you should find the default log location on App Server in c:\temp\log , there is no specific port as far as I'm aware, however should communicate over port 80 or 443 for http and https.

Hi @lajanakiram , 

Thank you for the prompt response. I found the log in C:\Temp\Log, and yeap it is showing connection failure. 

System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a send. ---> System.IO.IOException: Unable to read data from the transport connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond

 

I will try to allow port 80 and 443 in Firewall and see how it goes. Thank you again. 

0 Kudos