cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

FNMEA Migration/Upgrade

I need to replace FNMEA v15.5 running on Windows Server 2008R2 with FNMEA v2020R2 running on Windows Server 2016.

I haven't been able to find any general documentation on migrations. Is there a recommended process?

If I mount the existing database from the new installation, will the database be compatible, will it fail, get corrupted, or will the new installation perform some kind of upgrade to the database when it connects?

I inherited this system and don't have any experience with installing FNMEA, but I did go though moving the database to a new upgraded SQL Server a while back. Now I just need to get FNMEA up to date.

Thanks for any help,

JerryL

This thread has been automatically locked due to inactivity.

To continue the discussion, please start a new thread.

4 Replies

I was in similar situation last year, but running FNMEA 15.6 on linux and wanting to go to 2019R1.  There was no documentation from Flexera on this, so I opened a support case.  The recommendation was to upgrade sequentially through the releases, 15.5->15.6->15.8->....so on.   I upgraded to 15.7 (2016 R2) last fall, and just upgraded to 15.8 (2018 R1).   At the end of each upgrade, there is a step to run "flexnet upgradedb", which supposedly upgrade some of the DB tables.   So my guess is that Flexera does not have a single step to take a SQL database and ramp it up from 15.7 to 2020 R2, so you have to do this sequentially.  Yes, it's a pain.

0 Kudos

Hi,

When it comes to the application itself, you will need to uninstall the previous version to install the new version. As for the database it states in the FNMEA 2020 R1 installation document the following:

"The database upgrade script assumes that you are upgrading from an existing version 15.x, 14.x, or 12, to version 2020 r1 database. As a precaution, it is recommended that you back up the database before upgrading the database. The data in the database will be preserved and transformed if necessary"

Please also note that version 4.x of the agent is not supported with 2020 r1, so you will need to migrate your agents to 5.6 before the upgrade of your FNMEA

 

If you find my answer useful please give kudos, if my answer solves your issue, please make sure to mark as solution

@mcavanagh You mention uninstalling the previous version before installing the new version. Does that still apply if I'm installing the new version on another computer? (Old version is installed on Windows Server 2008R2; New version will be a different server running Windows Server 2016.)

Thanks for the feedback!

-JL

Hi @ATD_IT ,

No, that wouldn't apply for a new server, you wouldn't need to uninstall the old FNMEA, you would just install the new version of FNMEA on the new server, and then run the flexnet upgradedb command. 

as a consideration you would need to do is obtain a license for the new server

If you find my answer useful please give kudos, if my answer solves your issue, please make sure to mark as solution
0 Kudos