Summary
Error is thrown when an invalid license collection is specified
Symptoms
When accessing the Admin -> Site Management -> Settings tab. the following error is thrown:
Cause
The error is caused when an invalid SCCM collection is specified at either of the following settings:
- Admin |Site management | Settings | Website | Licensed Collection
- Admin |Site management | Settings | Website | Exclude Collection
This can happen when the SCCM Server information is changed to point to a different SCCM server and the above settings are still pointing to the old SCCM collections.
Resolution
To resolve the issue, run the following SQL queries against the App Portal database to remove any reference to the old SCCM collections.
Update WD_AppSettings set Value=?? where KeyName = ?LICENSECOLLECTIONID?
Update WD_AppSettings set Value=?? where KeyName = ?GLOBALCLIENTEXCLUSIONCOLLECTION? After the manual database update, do an IISRESET on the App Portal Server.