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Summary

When checking out a catalog item in ServiceNow, it is necessary to select a device to install software on. If no devices are available, then this typically indicates that the current user is not associated with any devices.

Symptoms

After selecting a catalog item, the user is prompted to "Select device to install software on". Upon searching for a device, none are found.

Cause

This will typically occur if the user account is not assigned to any computers. The user must be assigned to at least one computer in order to be able to select a device for checkout.

Resolution

To resolve the issue, it is necessary to associate at least one computer to the user account. This can be done by viewing a computer in ServiceNow, and setting the "Assigned to" property for the computer. The following screen capture shows this property:

Assigned To field

Note: In this screen caputure, the computer is associated with the System Administrator account.

Additional Information

For additional information on the checkout process for App Broker catalog items in ServiceNow, please see Requesting App Portal Catalog Items Using the ServiceNow Interface in the App Portal / App Broker Administration Guide.
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Version history
Last update:
‎Nov 07, 2018 05:04 PM
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