Summary
This article discusses how to resolve the issue where assets are not being added or removed from SCCM collections.
Symptoms
When new requests are submitted in App Portal, the assets are not being added to the App Portal collections within SCCM.
- The My Requests tab shows the status as "Pending Deployment".
- The CollectionInsert.log files show the insert counts increasing but not getting processed.
- The ESDWebService.log file on the SCCM server has the following error: Error processing insert for Request ID 1000 for collection ID CA100AAA Thread was being aborted.
The same issue could be seen in the CollectionClean.log where assets are not being successfully removed from the collections after requests are processed.
Cause
This issue is caused when a large number of records need to be processed by the App Portal web service and a timeout exception occurs. The timeout exception gets logged in the Event Viewer logs on the SCCM server.
Resolution
This particular issue can be resolved by increasing the execution timeout value (e.g to 6 min) on the SCCM server machine under IIS manager Sites | Default Web Site | ESDWebService | Configuration Editor | system.web/httpRuntime | executionTimeout