A new Flexera Community experience is coming on November 18th, click here for more information.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Summary

If the installer is failing with an error 1603, then this typically indicates a problem in configuring IIS. This will occur if the installer does not have permissions to modify web.config, or if the Default Web Site in IIS is not bound to port 80.

Symptoms

The App Portal 2017 installation may fail with MSI error 1603. The following may be seen in the MSI log created by the installer:
CustomAction ISIISInstall returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Action ended 14:12:41: InstallFinalize. Return value 3.

Cause

This may occur if the installer does not have permissions to write to the file C:\inetpub\wwwroot\web.config. The issue will also occur if the Default Web Site in IIS is not bound to port 80.

Resolution

Prior to installing, be sure that the user account performing the installation has the appropriate permissions to modify web.config. Also, be sure that there is a binding to port 80 on the default web site.. The following screen capture illustrates:

User-added image


Additional Information

The MSI log for the installer will be created in the %TEMP% directory. The file name will reflect the version of App Portal being installed. For example, the log file will be named App_Portal_2017_R1.log when installing App Portal 2017.
Was this article helpful? Yes No
No ratings
Version history
Last update:
‎Oct 18, 2018 06:16 PM
Updated by: