Showing results for 
Show  only  | Search instead for 
Did you mean: 


Login failed for user 'DOMAIN\MACHINENAME$' message seen after installing WFM and WFM database on different machines.


After installing WorkFlow Manager (WFM), one may see the error - 'Login failed for user 'DOMAIN\MachineName$'', where DOMAIN is the machine domain and and MachineName is the name of the machine.


If the WFM Server and the WFM database are installed on different machines, then you may run into this error. The 'WorkFlowManager' Application Pool used with the 'WorkFlow Manager Application' website is set to use the Identity as ApplicationPoolIdentity be default. The Identity attribute needs to be set to a domain user who has dbo access to the WFM database on the other machine.


To resolve this issue, please do the following -
  1. On the WFM Server machine, open 'IIS Manager'
  2. Click on the 'Application Pools' node here
  3. Right click on the 'WorkflowManager' application pool and select 'Advanced Settings'
  4. In the 'Advanced Settings' dialog, under the 'Process Model' section, click on the far right ('...') to change the 'Identity' attribute
  5. You will now see the 'Application Pool Identity' dialog, where select the 'Custom account:' and click on the 'Set...' button
  6. Here enter the domain credentials of an account, which has dbo access to the database. The user name needs to be entered in the format - domain\user
  7. Save the information and exit out of all the dialogs in IIS
  8. Restart IIS and close out any open Internet Explorer sessions
  9. Access the WFM site again

Additional Information

For more information on Workflow Manager Installation and Configuration, please refer to the Installation Guide
Was this article helpful? Yes No
No ratings
Version history
Last update:
‎Jan 08, 2013 11:40 AM
Updated by: