Summary
Login failed for user 'DOMAIN\MACHINENAME$' message seen after installing WFM and WFM database on different machines.
Symptoms
After installing WorkFlow Manager (WFM), one may see the error - 'Login failed for user 'DOMAIN\MachineName$'', where
DOMAIN is the machine domain and and
MachineName is the name of the machine.
Cause
If the WFM Server and the WFM database are installed on different machines, then you may run into this error. The 'WorkFlowManager' Application Pool used with the 'WorkFlow Manager Application' website is set to use the Identity as ApplicationPoolIdentity be default. The Identity attribute needs to be set to a domain user who has dbo access to the WFM database on the other machine.
Resolution
To resolve this issue, please do the following -
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On the WFM Server machine, open 'IIS Manager'
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Click on the 'Application Pools' node here
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Right click on the 'WorkflowManager' application pool and select 'Advanced Settings'
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In the 'Advanced Settings' dialog, under the 'Process Model' section, click on the far right ('...') to change the 'Identity' attribute
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You will now see the 'Application Pool Identity' dialog, where select the 'Custom account:' and click on the 'Set...' button
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Here enter the domain credentials of an account, which has dbo access to the database. The user name needs to be entered in the format - domain\user
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Save the information and exit out of all the dialogs in IIS
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Restart IIS and close out any open Internet Explorer sessions
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Access the WFM site again
Additional Information
For more information on Workflow Manager Installation and Configuration, please refer to the
Installation Guide