cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error-SOURCEFILEPATH

CChong
By Level 11 Flexeran
Level 11 Flexeran
Hi,
I hv created MSI using Repackager successfully, But when I create it assign the source path to the "SOURCEFILEPATH" variable of "Advanced Views" option automatically.. Now when I open this .MSI to different mechine and try to built it gives error about the ath variable, After changing this path variable it works filne.

Now my query is :
Is there any other way that it ask for the path automatically or can I set it at ther run time.

Thanks
(4) Replies
There are two ways I can think of:

1. use a UNC Path for the path variable, so its not machine specific

2. change the path variable type to registry or environment.
The source path can now be taken automatically from an evironment variable or a registry entry.

Hope it helps,
Marco
CChong
By Level 11 Flexeran
Level 11 Flexeran
Hi Macro,

Thanks for suggestion, But I do not know how to use UNC variable(What is UNC variable) can u guide me..

I hv tried with environment variable but it does not work..can u guide me how can I use it..

Thanks
Normally, I will keep application files referenced by SOURCEFILEPATH at a location relative to where ISM is located, so that SOURCEFILEPATH can have a value relative to . For example, the first 2 columns in Path Variable view,
Name             Defined Value
ISProjectFolder
SOURCEFILEPATH \Source
Whenever I move them, I move them as a group, this will make sure the package can be built when moved to a different machine.
CChong
By Level 11 Flexeran
Level 11 Flexeran
This was default in installshield 3, what possesed installshield to change it in version 5 is beyond me.
Top Kudoed Authors