imcginley_in
Level 3

Connecting Jamf/Casper to AdminStudio SSL/TLS error.

Hello,

We are trying to get AdminStudio and Jamf/Casper talking. We're attempting to make this connection in Adminstudio App Catalog > Options > Distribution System. We made a new item and selected Casper Distribution Plugin, and filled in the server info. But in the 'Share Information' section when we try to select a DP an error pops up 'The request was aborted: Could not create SSL/TLS secure channel'.

Any advice on resolving this would be greatly appreciated.

 

Thank you.

 

- Ian

0 Kudos

This thread has been automatically locked due to inactivity.

To continue the discussion, please start a new thread.

7 Replies
bkelly
Moderator Moderator
Moderator

Are you using the latest version of AdminStudio? In AdminStudio 2018 R4 a bug was addressed where AdminStudio could not connect to SQL running in a TLS 1.2 only environment.

Also, the capability was designed to support the on-premise version of Casper; perhaps you are attempting to connect to a cloud instance? 

If this is not helpful, I'd suggest a situation like this may best be handled via a support ticket. 

0 Kudos

We are on 16.01 R2. We are not connecting to a cloud. We are testing this in our air-gap environment just to test out ability to use Jamf.

0 Kudos

That is definitely a supported configuration- this being the case, please open a support ticket so we can help troubleshoot the issue and get it working as expected.
0 Kudos

Meanwhile, please check if TLS is enabled on both AdminStudio and the Jamf machines.
0 Kudos

TLS is enabled.

0 Kudos
imcginley_in
Level 3

I put in a request last week and have not gotten a response yet. This issue is still open.

0 Kudos

Just to update the forum members, we have an open support case with our Technical Support team around this issue. We're looking into the cause and will have additional information when we determine the root cause.
Expert Flexeran on AdminStudio, Workflow Manager, and Software Vulnerability Manager / Research
If I've answered your question, please mark my response as "Accept as Solution" to help others find answers. Thanks!