Showing results for 
Show  only  | Search instead for 
Did you mean: 

9.0 merge module issue

I'm using admin studio 9.0 to repackage Rapid SQL 7.7.0. This package include vc 9.0 merge modules in the .irp file. They are located at C:\windows\winsxs (ATL, CRT, MFC modules). They show up correctly in the .irp file but not the .ism file and are not installed when I run the msi. When I run the MSI there are 9.0 merge modules installed but they are the wrong version, 9.0.21022.8. The version in the .irp file is 9.0.30729.1. Therefore, when I run the shortcut after installing my package I get an error, "The application failed to initialize properly (0xc0150004)."

I believe it's because the correct version is not being installed for these merge modules. Any ideas on why my package is not installing the correct version?

Any help would be greatly appreciated!

(1) Reply
Selecting the correct side-by-side (sxs) merge modules is one of the more complex parts of the Repackaging process. You may be able to alter which merge modules are present in the Modules\i386 sub-folder of Repackager.

There is a file in the System sub-folder of Repackager that controls which merge module gets substituted for a given assembly - PlatformFilesToModules.ini. It may be possible to modify this to select a newer version of the merge module as a replacement.

If you just want to work-around this issue, you can open the ISM file in InstallShield Editor and remove the older merge modules in the Redistributables view and browse for the correct merge modules. Then build the MSI from here, and you should be good to go.