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Summary

OneSearch not working for Spider Knowledge Base 4.5.20 after updating to Spider Operations Manager 4.6.3

Cause

Updated Spider KnowledgeBase 4.5.20 module in OperationsManager 4.6.3 requires enhanced index search result renderer to find and correctly display any results..

Resolution

  1. Stop brainwaregroup ESI service: "net stop indexproxy" or use Services Console (display name: "index GlassFish Server")
  2. Copy attached MOD_KB.jar file to ESI installation folder e.g. "C:\Program Files (x86)\ESI\3rdparty\payara-4.1\glassfish\domains\index\autodeploy\indexproxy\onesearch_preparers" overwriting the previous version.
  3. Start brainwaregroup ESI service: "net start indexproxy" and wait until initialised.
  4. If not already done, continue patching OperationsManager to version 4.6.3

Additional Information

If still no KB articles are found after manually updating ESI service, try rebuilding index of Spider Knowledge Base from within KB Configuration web page > Index > Rebuild Index

Products

OM4, ESI

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Version history
Last update:
‎Aug 26, 2019 11:17 AM
Updated by: