stefbed
Pilgrim

"Unable to upgrade the template file" ???

I captured with repackager to testing my template.

When i opened .irp project, all are ok.

When i build to create .ism, i have always error message...
-------------------------------------------
Wednesday, February 06, 2013 01:02:20PM

Starting conversion ...
Creating InstallShield project: C:\Packages\Test\MSI_Package\test.ism
Checking version of template file 'C:\Packages\Test\Modele_1.2.ism'
Unable to upgrade the template file.

Conversion stopped with one or more error(s).

-------------------------------------------


If i use the "default Editor template", it's ok (???)
I create model with Installshield 2012 Spring Premier SP1 [v19.0.0.185]
I capture with Installshield Repackager 11.0.0.340 (it come with Installshield 2012 Spring Premier)

I check security and ajust to "users" ti have all access.
I open .irp with "run as administrator"

Always the same error appear !

My OS: Windows 7 Pro SP1 x64 with 24gb of memory, cpu i7.

How can i resolve it ??
Labels (1)
0 Kudos
2 Replies
ekgcorp
Pilgrim

I'm having the exact same issue. Only difference is my pc has 16gb of ram and not 24.

I did the capture from a VM using Remote Repackager. I even made sure that Installshield Spring was updated to the latest version.

Lastly, I tried to open up template file within InstallShield 2012 Spring and saved it. So I have one template that is saved via Spring and one that is not. Neither one of them work. They both get the same error.

...Copied from Log File...
Tuesday, October 08, 2013 08:42:33AM

Starting conversion ...
Creating InstallShield project: C:\Packages\TimeValue TaxInterest 2013.4\MSI_Package\TaxInterest.ism
Checking version of template file 'I:\_Template\Base_Template.ism'
Unable to upgrade the template file.
...Copied from Log File...

Conversion stopped with one or more error(s).
0 Kudos
ekgcorp
Pilgrim

I had modified the Template I was trying to use with 2012 Spring. When you do, you might see another file in same directory with an extension of .722... This is a backup created by opening up an older ISM with 2012 Spring.

FYI, you can still get to version 2012 (non-Spring) shortcut. This is what is used by Remote Repackager, so when you try and apply a Template file that is from 2012 Spring, you will get the above error.

The bottom line is, if you use Remote Repackager, make sure your template file is of the same 2012 version, and not 2012 Spring.
0 Kudos