cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
ireznik
Flexera beginner

"Edit prerequisite" menu item disabled

InstallShield 2016 Professional was successfully transferred to another machine. Proper installation project runs on new machine. However, Installation Designer => Application Data => Redistributables => Right click on a prerequisite => Edit prerequisites menu item is disabled. It was enabled on old machine and need to be enabled on new machine.

How to fix this?

Thanks.

image.png

0 Kudos
9 Replies
Flexera Jenifer
Flexera

Re: "Edit prerequisite" menu item disabled

Hi @ireznik ,

 

Can you please check whether the selected pre-requisite file exists in default SetupPrerequisites folder (Eg:C:\Program Files (x86)\InstallShield\2016\SetupPrerequisites) or in folders added under Tools->Options->Prerequisites tab?

If it doesn't exist,please try placing the .prq file in that folder,you will be able to see Edit prerequisite option been enabled.

 

Thanks,

Jenifer

0 Kudos
ireznik
Flexera beginner

Re: "Edit prerequisite" menu item disabled

Thanks, Jenifer.

Yes, the prerequisite exists in …SetupPrerequisites folder.  However, the item is disabled. Please see crop of screenshot. Just in case, contents of the file is shown too.
Post to forum 2.png

0 Kudos
Flexera Jenifer
Flexera

Re: "Edit prerequisite" menu item disabled

Hi @ireznik ,

 

Thanks for the information.I might need some details from you to assist you with:

  • Generally Edit Prerequisite will get disabled on having pre-requisite name empty or SetupPrequisite path variable <ISProductFolder>\SetupPrerequisites doesn't get resolved properly
  • Can you check the value of <ISProductFolder> in the machine where you had moved,gets resolved properly?-If not please change the value of <ISProductFolder> accordingly(Which applies to the current mahcine) and give it a try.
  • If that is the case Edit Prerequisite  option gets disabled for all pre-requisites.Is that true?

 

Thanks,

Jenifer

 

0 Kudos
ireznik
Flexera beginner

Re: "Edit prerequisite" menu item disabled

Thanks, Jenifer.

 <ISProductFolder> value displayed in Media/Path variables window is" C:\Program Files (x86)\InstallShield\2016\" (without quotes), the directory where Installshield is installed:

image.png

Is this correct? 

At the same time "Edit prerequisite" item is disabled for all redistributables I tried.

Thanks,

Ilia.

0 Kudos
Flexera Jenifer
Flexera

Re: "Edit prerequisite" menu item disabled

Hi @ireznik ,

 

<ISProductFolder> seems to be correct,one more check would be which i had initially asked :

  • Could you see folder values under Tools->Options->Prerequisites tab?It would be added by default to Prerequisite File locations(For All users),the value has to be  C:\Program Files (x86)\InstallShield\2016\SetupPrerequisites.If not please update and try
  • If that also doesn't seem to be working,there is something else which might be unknown causing the issue.

Hope you are aware about the work-around,i.e using prerequisite editor (Tools->Prerequisite Editor) you can still edit the .prq file.

 

Thanks,

Jenifer

Thanks,

Jenifer

0 Kudos
ireznik
Flexera beginner

Re: "Edit prerequisite" menu item disabled

Thanks, Jenifer.


Tools->Options->Prerequisites are set as:

image.png

And below is contents of the folder mentioned:

image.png

I see nothing wrong here. Did not try yet direct using Tools->Prerequisite editor, but all the conditions which where set on old machine are empty there... In any case I'd prefer to work old way, with "Edit prerequisite" item enabled. Is it really impossible?

Thanks, Ilia.

0 Kudos
Flexera Jenifer
Flexera

Re: "Edit prerequisite" menu item disabled

Hi @ireznik ,

 

can you tell us how did you transfer between machines?

Hope it is professional to professional edition.

  • How did you transfer .prq files?
  • Did you do file comparision of both the .prq files between two machines?You could see conditions related data been missed out?

If nothing helps, sharing project files would help us check further.

 

Thanks,

Jenifer

0 Kudos
ireznik
Flexera beginner

Re: "Edit prerequisite" menu item disabled

Yes, both are 2016 Professional editions.

  • How did you transfer .prq files? - Don't remember for sure, but most probably I copied them to the same location on new machine.
  • Did you do file comparision of both the .prq files between two machines? The files are the same. For 
    "Microsoft Visual C++ 2015 Redistributable Package (x86).prq" contents is 

    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <SetupPrereq>
    <conditions>
    <condition Type="32" Comparison="2" Path="HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DevDiv\VC\Servicing\14.0\RuntimeMinimum" FileName="UpdateVersion" ReturnValue="14.0.23026"/>
    </conditions>
    <files>
    <file LocalFile=".\VC 2015 Redist\vc_redist.x86.exe" URL="https://download.microsoft.com/download/9/3/F/93FCF1E7-E6A4-478B-96E7-D4B285925B00/vc_redist.x86.exe" CheckSum="1A15E6606BAC9647E7AD3CAA543377CF" FileSize="0,13767776"/>
    </files>
    <execute file="vc_redist.x86.exe" cmdline="/q" cmdlinesilent="/q" returncodetoreboot="1641,3010"/>
    <properties Id="{29AE0051-88F8-4ED7-A6F9-7EA37A6B11A3}" Description="This prerequisite installs the Microsoft Visual C++ 2015 Runtime Libraries (x86). " AltPrqURL="http://saturn.installshield.com/is/prerequisites/Microsoft Visual C++ 2015 Redistributable Package (x86).prq"/>
    <behavior Hidden="1" Failure="4" Reboot="2"/>
    </SetupPrereq>

    For file Microsoft Access Database Engine 2010 Redistributable.prq difference is in location:
    Old machine:
    <files>
    <file LocalFile="<ISProductFolder>\SetupPrerequisites\AccessDatabaseEngine.exe " CheckSum="F0CFC4CAB419FE0C85604B78D1D20DFE" FileSize="0,26554784"/>

    New machine
    <files>
    <file LocalFile="c:\Users\ireznik\Downloads\AccessDatabaseEngine.exe " CheckSum="F0CFC4CAB419FE0C85604B78D1D20DFE" FileSize="0,26554784"/>
    </files>

    But both locations are correct. And, remember, "Edit prerequisite" is disabled for all prerequisites.

    If nothing helps, sharing project files would help us check further. - That's great, but  I could not find option to attach files. How can we share projects?

    Thanks,
         Ilia.


    </files>
0 Kudos
Flexera Jenifer
Flexera

Re: "Edit prerequisite" menu item disabled

Hi @ireznik ,

 

You can add relevant files required to build project file( .ism) successfully and zip it.You will see choose files option right down here where you reply currently,attach it.

Just to confirm you using InstallShield 2016 professional not service pack right?This is to reproduce the scenario since i couldn't reproduce here.

 

Thanks,

Jenifer

0 Kudos