cancel
Showing results for 
Search instead for 
Did you mean: 
Raghvendra
Pilgrim

problem in launching a exe file using installer (Basic MSI)

Hey All,
I made a installer Using Basic MSI and I written a custom Action for this, which installs a ".AIR" file using "airappinstaller.exe".
The working of my Intsaller (Basic MSI) is-
Firstly put some folder and setups file in program data and program files then check that weather "Adobe AIR" installed or not if not then install the "AdobeAIRAppInstaller.exe" then launch "airappinstaller.exe" and finally launch my "*.air" file.

The Problem is, when I start the installer then it's check that Adobe AIR installed or not, but when it found that Adobe Air not installed on system then installer trying to launch AdobeAirAppInstaller.exe and it launch fine but suddenly Adobe Air prompt a message "Another Installation is in progress" and does not install Adobe AIR. So I think the problem is that the Installshield installer is also in progress and same time Adobe Air trying to install. So i need to terminate the install shield installer firstly then I have to launch my AdobeAirAppInstaller.exe but I am facing very much difficulty to remove this problem. please help me on this.

my sequence setting is
[SIZE=2][install UI Sequence = ]
[install exec sequence = ][/SIZE]

Thanks
Labels (1)
0 Kudos
2 Replies
Flexera tjohnson1
Flexera

Re: problem in launching a exe file using installer (Basic MSI)

I would sugest creating a prerequisite for Adobe Air and include it to your project. This will perform the check before your install starts and allowing the Adobe Air install to run.

http://kb.flexerasoftware.com/doc/Helpnet/installshield18helplib/SetupPrereqEditor.htm
0 Kudos
Highlighted
Raghvendra
Pilgrim

Re: problem in launching a exe file using installer (Basic MSI)

tjohnson1 wrote:
I would sugest creating a prerequisite for Adobe Air and include it to your project. This will perform the check before your install starts and allowing the Adobe Air install to run.

http://kb.flexerasoftware.com/doc/Helpnet/installshield18helplib/SetupPrereqEditor.htm


Hey Thanks tjohnson.
0 Kudos