cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Flexera beginner

VersionNT Property giving wrong value when we call from bootstrapper


Hi Support,

We are restricting Installer not to launch in few OS by setting property VersionNT property in launch conditions.

Ex:(Not Version9X) And (Not VersionNT=400) And (Not VersionNT=500) And (Not VersionNT=501) And (Not VersionNT=502) And (Not VersionNT=600)

Recently we have add restriction for Win7 and Win8 and we used VersionNT 601 and Version NT 602 value, it is working fine in normal installation.

Ex:(Not Version9X) And (Not VersionNT=400) And (Not VersionNT=500) And (Not VersionNT=501) And (Not VersionNT=502) And (Not VersionNT=600) And (Not VersionNT=601)

But we have client installation using a utility, we call msi from bootstrapper , in that API MsiSetInternalUI is giving VersionNT value always 602 even for Windows8.1 or Windows10 because of that our condition failing.

Help us with how to handle OS restrictions?

Labels (1)
0 Kudos
1 Reply
Highlighted
Flexera
Flexera

Re: VersionNT Property giving wrong value when we call from bootstrapper

Hi @Surya0152 ,

The installer sets the VersionNT property to the version number for the operating system, undefined if the operating system is not Windows NT, Windows 2000, Windows XP, Windows Vista, Windows Server 2008, or Windows 7. The value is an integer: MajorVersion * 100 + MinorVersion.

Which type of Installshield project it is?

Thanks,

Jenifer

0 Kudos