[Incident]: Some users report they are unable to access the case portal. Please see this community notice for more information.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
darshan_mbm
Level 3

Problem After upgrade

Hi,

I am working on a Basic MSI project using Installshield 2008.
I have noticed that the [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{ProductCode}\] registry entry is removed on uninstall after the first installation, but if i apply a minor upgrade and then uninstall the application than this entry is not getting removed.

So after that if i try to reinstall the application it take me to the maintenance mode.

Let me describe the procedure:
Install version 1.0 of my product.
Perform a minor upgrade using the version 1.1 of the MSI package.
The above registry entry is still present.
Now if I directly uninstall than the entry does not go. and the product is still shown in add remove programs

Is that behaviour normal?

ISSUE-1
--------
Than i i try to install 1.1 then it takes me to reinstall mode...
and if i try to install 1.0 than it prompts that other version of the product is already installed.

command used to upgrade is
MSIEXEC /i "Client.msi" REINSTALLMODE="va" REINSTALL="ALL"

ISSUE-2
--------
After upgrading if i uninstall the application than it is still executing the old script code... that means that still old msi is cached.
Labels (1)
0 Kudos
2 Replies
kirann_hegde
Level 5

Hello,

Is there a reason why you are using REINSTALLMODE="va" for your upgrade?


To recache the new msi you need to use REINSTALLMODE="vomus".

Regards,
Kiran Hegde
0 Kudos
darshan_mbm
Level 3

I am using 'va' instead of 'vomus' .. because i want to replace all file irrespective of file version. m-u-s are for re-cache HKEY_LOCAL_MACHINE , HKEY_USER, and shortcuts entries respectively.
0 Kudos