selwynreynolds
Level 7

Not installing to Program Files on Win 7 x64

I have converted an InstallShield 2011 InstallScript MSI Project to InstallShield 2012. Our software requires it to be in Program Files not Program Files (x86). I set INSTALLDIR to ProgramFiles64 and this worked on the 2011 install. Now when I run the 2012 install it is putting the files in Program Files(x86). I stepped through the installed to look at the variables and INSTALL and TARGETDIR are both set to \Program Files NOT \Program Files (x86). Why are my files being put in \Program Files (x86) instead of \Program Files?

I have the Template Summary in the Release set to x64;1033

I tried setting the 64-Bit Component property of one of my components to Yes (all others are set to NO and were in the 2011 project, which worked) to see if that particular component would be installed in Program Files but that causing a compile error: "An unexpected error occurred embedding file c:\program files (x86)\InstallShield\2012\Redist\Language Independent\x64\ISBEW64.exe into c:\InstallastionFolder\Interim\isregsvr.dll

What is wrong with my project?

Thanks!
Labels (1)
0 Kudos
1 Reply
scottd72
Level 7

Is your INSTALLDIR folder located under ProgramFilesFolder? If so it's going to install to the 32 bit program files folder every time, no matter what.

I think I had a similar issue. What I have done is created my own folder called PROGRAMFILESFOLDER, and created my INSTALLDIR folder underneith that. Then I created two custom actions: SetPROGRAMFILESFOLDERx64 and SetPROGRAMFILESFOLDERx86. For the SetPROGRAMFILESFOLDERx64 condition I specified "VersionNT64" and gave the directory name PROGRAMFILESFOLDER the value of [ProgramFiles64Folder].
0 Kudos