cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
ghostfacesuk
Level 2

.Net 3.5 redistributable issues Windows 7

Hello all,

This is my first post here.

I have been using Install Shield 2009 and ran into a problem. I am trying to create an installation that runs on Windows XP, Windows Vista and Windows 7. Problem is the exe file I am trying to install on the target PC requires .Net 3.5 sp1.

I believe Windows 7 does not need this installed as its already on there. However Vista and XP do need it.

Is there a prerequisite or some sort of condition I can set on the redistributable to only install on the machine if its Vista or XP?


Thanks,
Steve
Labels (1)
0 Kudos
3 Replies
CChong
Level 11 Flexeran
Level 11 Flexeran

I recommend you create a prerrequisite for your installer, in this way it will detect when the system doesn't have .NET 3.5 installed and will install it for you (which I think will not happen on Win 7).

I recently did it in InstallShield 12 with .NET 3.5 (no SP), but the procedure should be basically the same for InstallShield 2009 and .NET 3.5 SP1.

Christopher Painter has written a very detailed procedure on how to do it in the following post: http://blog.deploymentengineering.com/2006/11/using-installshield-12-to-install-net.html

Just remember that when you finish creating your prerequisite, you need to add it to your project by going to Application Data --> Redistributables and then filtering Setup Prerequisites.

Hope it helps.

Regards,
Juan Carlos
0 Kudos
CChong
Level 11 Flexeran
Level 11 Flexeran

Forgot to mention,

If you want to keep your package small you should probably redistribute only the .NET 3.5 sp1 bootstrapper, which will force your users to connect to the internet and download the full package (this is very transparent and painless if the connection is working fine).

If your clients are not guaranteed to have internet access, you should then redistribute the full package, but it is more than 200Mb.

Regards,
Juan Carlos
0 Kudos
DebbieL
Level 17

InstallShield 2009 SP2 includes a .NET Framework 3.5 SP1 prerequisite.

To obtain SP2, see the link near the bottom of the Read Me First community sticky post in this InstallShield 2009 forum.
0 Kudos