Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 3

Installer works on windows 10, but on windows 11 is causing a problem

When i run the exact same installshield installer on a windows 11 macahine, several of my items won't load.  When running this through a debugger, i get "comexception, class not egistered" (exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG).    


Is this something that installshield isn't installing properly and if so, how can i rectify it? Thank you.

Labels (1)
0 Kudos
(3) Replies
Revenera Moderator Revenera Moderator
Revenera Moderator

Hi @nope123 ,

 You are using installshield express2019 version?

what do you mean "When running this through a debugger,"?  Could you please share screenshot, what command you are using to debug it? 

Did you mean to say you are facing an issue on running your installer it crashes on win11 machine? Could you please share installation verbose log.

If you create a dummy project and if you install it you are able to see the same behavior?

0 Kudos

Sorry i was unclear.  When running our own source code through the debugger.  I'm using visual studio if its relevent.  But I have read one suggestion for a solution would be to run RegSvr32  on each of the dll's involved.  My curiosity is, why would this process have worked successfully (and still does) on a windows 10 machine, but not a windows 11 machine running the same installer?        To answer your second question, i don't have a minimal example i can use in this case to reproduce the issue.  But i can say with confidence that nothing has changed except the OS.  I can use the same installer now, on a brand new windows 10 machine, and it'll work just fine.  But on a windows 11 machine, i'll have the problem listed in the first post.

0 Kudos

I have figured out the issue, but not its cause.  5 ocx files that were previously being registered just fine by the installer, on windows 11 are not being even copied into the correct place (syswow64) let alone registered.  Does anyone know what the cause could be? There are no changes to the installer project at all.  I know this is the correct answer, because if i copy the ocx files and regsvr32 them by hand, the application works as expected.

0 Kudos