cancel
Showing results for 
Search instead for 
Did you mean: 
lrobi158
Pilgrim

Installed ISLE, but no deployment or IS options listed in "New Project" window

I'm using VS2012 Professional. I installed first ISLE12 (VS was not open). Per the directions, I opened a VS project, navigated to File->Add->New Project. In the New Project window under "Other Project Types" there is no option "Setup and Deployment" item. Rebooted computer--still not available.
Installed ISLE15 hoping it would work, but had the same result. What do I have to do to have access to the ISLE project template?
0 Kudos
8 Replies
Flexera jlynch11
Flexera

Re: Installed ISLE, but no deployment or IS options listed in "New Project" window

Were you able to activate ISLE? Try opening InstallShield from the Start menu >All Programs >InstallShield > InstallShield 2015 Limited Edition. It should open up in Visual Studio if it is activated; if not, the activation screen will pop up. Complete the activation and the project type should show up.

If the product is activated and you still don't see the project type, you can use TSConfig.exe to repair the Visual Studio integration. Do do this, close InstallShield / Visual Studio, open a command prompt, and navigate to the default location:

C:\Program Files (x86)\InstallShield\2015LE

run this command to repair the integration: TSConfig /repairvsip

Note: You can also trigger the ISLE activation by running TSConfig /activate

I hope this helps.
0 Kudos
lrobi158
Pilgrim

Re: Installed ISLE, but no deployment or IS options listed in "New Project" window

jlynch11 wrote:
Were you able to activate ISLE? Try opening InstallShield from the Start menu >All Programs >InstallShield > InstallShield 2015 Limited Edition. It should open up in Visual Studio if it is activated; if not, the activation screen will pop up. Complete the activation and the project type should show up.

If the product is activated and you still don't see the project type, you can use TSConfig.exe to repair the Visual Studio integration. Do do this, close InstallShield / Visual Studio, open a command prompt, and navigate to the default location:

C:\Program Files (x86)\InstallShield\2015LE

run this command to repair the integration: TSConfig /repairvsip

Note: You can also trigger the ISLE activation by running TSConfig /activate

I hope this helps.


I was able to activate prior by manually running tsconfig by browsing to it via windows explorer (this was done prior to posting in the forum, just forgot to mention it). I tried your advice with the "TSConfig /repairvsip" command, but it did not resolve the issue.
0 Kudos
Highlighted
Flexera jlynch11
Flexera

Re: Installed ISLE, but no deployment or IS options listed in "New Project" window

Could you post a screenshot of what are seeing when you go to File->Add->New Project>Other project types?
0 Kudos
lrobi158
Pilgrim

Re: Installed ISLE, but no deployment or IS options listed in "New Project" window

Please see attached requested screenshot.
0 Kudos
lrobi158
Pilgrim

Re: Installed ISLE, but no deployment or IS options listed in "New Project" window

bump.... Any ideas why I'm not able to use a deployment project?
0 Kudos
Flexera jlynch11
Flexera

Re: Installed ISLE, but no deployment or IS options listed in "New Project" window

If you go to help about > Microsoft Visual Studio, you should see a list of installed products. Is InstallShield Limited Edition listed in there? If it is not present try registering ISLE manually through the following steps:

1. Use RegSvr32.exe to register IsLimEdt.dll, IsLimPkg.dll, and IsLimWiz.dll which are found in the System sub-directory of the main InstallShield installation directory location.
2. Locate devenv.exe corresponding to the version of Visual Studio.NET you are interested in. For example, InstallShield 2013 supports Visual Studio.NET 2012 and this is located in the following folder: C:\Program Files\Microsoft Visual Studio 10\Common7\IDE
3. Run devenv.exe /setup in a command prompt (DOS) window.

I hope this helps.
0 Kudos
lrobi158
Pilgrim

Re: Installed ISLE, but no deployment or IS options listed in "New Project" window

I followed jlynch11's suggestions--Install shield was not in the list of installed products, so i registered the dlls and ran devenv command as described in jlynch11's post. However after following this advice, it is still not listed in the installed products list, or the add project dialog.
0 Kudos
lrobi158
Pilgrim

Re: Installed ISLE, but no deployment or IS options listed in "New Project" window

bump... Any additional ideas? Nothing I'm trying has any result. Any way to get a log from the installation attempts (even though it claims successful), verify values that should be getting put in place in the registry, etc etc? Can it be installed manually somehow from inside visual studio? This should not be so hard.
0 Kudos